質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.75%

  • Ruby

    7016questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6737questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Rails4と5のgem fileの違いについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 259

WalterMontes

score 8

現在youtubeを見ながらrailsでアプリを作っているのですが、rails4で解説しているので私が使っているrails5とはgem fileの書き方が異なっています。
rails5ではGemfileの先頭に以下のコードが挿入され、調べたところこれはGemfileの中で:githubオプションをつけたgemについてHTTPS経由でGithubから取得し、引数のオプションがついたgemの取得先URLをブロック内で指定することができるものだとわかりました。
git_source(:github) do |repo_name|
repo_name = "#{repo_name}/#{repo_name}" unless repo_name.include?("/")
"https://github.com/#{repo_name}.git"
end
動画では新たに以下のgemを追加していますが、rails5のgemfileでは以下のgemをどこに追加すればようでしょうか。またはバージョンを動画に合わせてrails4にして動画の通りにgemfileを作成すべきでしょうか。
gem 'simple_form', '~> 3.0.2'
gem 'haml', '~> 4.0.5'
gem 'bootstrap-sass', '~> 3.2.0.2'
リンク内容
![イメージ説明]
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

group内もしくはオプション内に、
gemを置かなければbundle installされるごとに
必ずインストールされます。

groupまたオプションでは、
bundleでインストールする際にskipオプションなどを
使ってインストールをスキップしたりすることもできます。

下記のようにバージョンを指定しけなければ、
常に最新のものがインストールされます。
gem 'simple_form'
gem 'haml'
gem 'bootstrap-sass'
また、
バージョンを指定している場合は、
常に指定されたバージョンがインストールされます。
gem 'simple_form', '~> 3.0.2'
gem 'haml', '~> 4.0.5'
gem 'bootstrap-sass', '~> 3.2.0.2'

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.75%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    xcodeでの画面サイズ変更方法

    swiftでサンプルコードを写しているのですが、参考書を今まで放置してたのでxcodeのバージョンが違うので画面サイズ変更の方法がわからないです。 simulatorでの表示画面

  • 解決済

    Blender Game Engineでマテリアルを透過したい

    Blenderでゲーム開発をしようとしているものです。 Blender Renderで透過処理したマテリアルをBlender Gameに反映させたいと思っているのですが、透過でき

  • 解決済

    tableview row(cell)

    コード import UIKit class ViewController: UIViewController, UITableViewDelegate, UITableView

  • 解決済

    SQLパラメーター式テーブルの値をand検索する

    実現したいこと fruit_id : 1 -> apple fruit_id : 2 -> mikan fruit_id : 3 -> banana テーブル名 : f

  • 解決済

    Ruby on rails

    前提・実現したいこと Ruby on railsのテスト環境構築中です ターミナルから rails s  しても下記のエラーでつまずいています 発生している問題・エラ

  • 解決済

    ViewControllerのInterfaceについて

    アプリ開発初心者です。 [目的]新たなViewControllerに機能を加えるためのファイルの場所を知る。 [現在の状況]ViewControllerを新規作成しましたが

  • 解決済

    cloud9 エディタ、ターミナルが表示されない

    ###前提・実現したいこと cloud9で作業中、どこか変なところを押したのかエディタが表示されなくなりました。 戻すために更に色々いじると何も表示されなくなりました。 元の画

  • 解決済

    AWS/EC2/RDS/ELB/nginx/unicornでデプロイ。

     参考記事 http://qiita.com/iwaseasahi/items/d5f2ef3eac5e349a8f7d 5まで行いました。  現在の問題。 ELB(ロードバラ

同じタグがついた質問を見る

  • Ruby

    7016questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6737questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。