質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.62%

  • Ruby on Rails

    6963questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    2402questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

rails runner実行時に一度だけBundler::GemRequireErrorが発生した原因について

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 240

hn1

score 273

cronで毎分実行しているrails runner処理で以下のエラーが発生しました。
一度エラーが発生しただけで、次回以降は正常に処理が行なわれています。
このエラーが発生した原因について何かわかるでしょうか。

bundler: failed to load command: bin/rails (bin/rails)
Bundler::GemRequireError: There was an error while trying to load the gem 'less-rails'.
Gem Load Error is: undefined method `call' for #<V8::Object:0x007f31d85ba868> Backtrace for gem load error is:
/var/www/vendor/bundle/ruby/2.2.0/gems/commonjs-0.2.7/lib/commonjs/environment.rb:18:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/commonjs-0.2.7/lib/commonjs/module.rb:18:in `block in require_function'
at /var/www/vendor/bundle/ruby/2.2.0/gems/less-2.6.0/lib/less/js/lib/less/index.js:128:1
/var/www/vendor/bundle/ruby/2.2.0/gems/commonjs-0.2.7/lib/commonjs/environment.rb:18:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/less-2.6.0/lib/less/loader.rb:28:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/less-2.6.0/lib/less.rb:15:in `<module:Less>'
/var/www/vendor/bundle/ruby/2.2.0/gems/less-2.6.0/lib/less.rb:9:in `<top (required)>'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'
/var/www/vendor/bundle/ruby/2.2.0/bundler/gems/less-rails-946213803a5b/lib/less/rails.rb:6:in `<top (required)>'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `block in require'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:240:in `load_dependency'
/var/www/vendor/bundle/ruby/2.2.0/gems/activesupport-4.2.7.1/lib/active_support/dependencies.rb:274:in `require'
/var/www/vendor/bundle/ruby/2.2.0/bundler/gems/less-rails-946213803a5b/lib/less-rails.rb:1:in `<top (required)>'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:82:in `require'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:82:in `block (2 levels) in require'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:77:in `each'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:77:in `block in require'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:66:in `each'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:66:in `require'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler.rb:108:in `require'
/var/www/xxxx/config/application.rb:8:in `<top (required)>'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/runner.rb:51:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/runner.rb:51:in `<top (required)>'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:123:in `require'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:90:in `runner'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands.rb:17:in `<top (required)>'
bin/rails:9:in `require'
bin/rails:9:in `<top (required)>'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/cli/exec.rb:74:in `load'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/cli/exec.rb:74:in `kernel_load'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/cli/exec.rb:27:in `run'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/cli.rb:362:in `exec'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in `invoke_command'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/vendor/thor/lib/thor.rb:387:in `dispatch'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/cli.rb:22:in `dispatch'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/vendor/thor/lib/thor/base.rb:466:in `start'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/cli.rb:13:in `start'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/exe/bundle:30:in `block in <top (required)>'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/friendly_errors.rb:121:in `with_friendly_errors'
/home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/exe/bundle:22:in `<top (required)>'
/home/opsuser/.rbenv/versions/2.2.4/bin/bundle:23:in `load'
/home/opsuser/.rbenv/versions/2.2.4/bin/bundle:23:in `<main>'
Bundler Error Backtrace:

  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:85:in `rescue in block (2 levels) in require'
  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:81:in `block (2 levels) in require'
  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:77:in `each'
  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:77:in `block in require'
  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:66:in `each'
  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler/runtime.rb:66:in `require'
  /home/opsuser/.rbenv/versions/2.2.4/lib/ruby/gems/2.2.0/gems/bundler-1.15.4/lib/bundler.rb:108:in `require'
  /var/www/xxxx/config/application.rb:8:in `<top (required)>'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/runner.rb:51:in `require'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/runner.rb:51:in `<top (required)>'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:123:in `require'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:90:in `runner'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
  /var/www/vendor/bundle/ruby/2.2.0/gems/railties-4.2.7.1/lib/rails/commands.rb:17:in `<top (required)>'
  bin/rails:9:in `require'
  bin/rails:9:in `<top (required)>'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails

    6963questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    2402questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。