質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.99%

  • Ruby

    6391questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6223questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

rails tutorialにおけるcloud9からHerokuへのデプロイ作業

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 340

zwtk

score 3

rails tutorialにおけるcloud9からHerokuへのデプロイ作業においてつまづいてしまい、2日程調べているのですが未だに解決しません。。
現在以下の様な状況です。
ご教授頂ければ幸いです。宜しくお願い致します。

:~/workspace/toy_app (master) $ git push heroku master
Counting objects: 92, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (78/78), done.
Writing objects: 100% (92/92), 21.60 KiB | 2.40 MiB/s, done.
Total 92 (delta 6), reused 0 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote: 
remote:  !     Warning: Multiple default buildpacks reported the ability to handle this app. The first buildpack in the list below will be used.
remote:                         Detected buildpacks: Ruby,Node.js
remote:                         See https://devcenter.heroku.com/articles/buildpacks#buildpack-detect-order
remote: -----> Ruby app detected
remote: -----> Compiling Ruby/Rails
remote: -----> Using Ruby version: ruby-2.3.4
remote: -----> Installing dependencies using bundler 1.15.2
remote:        Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
remote:        Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.16.0.pre.2). We suggest you upgrade to the latest version of Bundler by running gem install bundler --pre.
remote:        You are trying to install in deployment mode after changing
remote:        your Gemfile. Run bundle install elsewhere and add the
remote:        updated Gemfile.lock to version control.
remote:        The dependencies in your gemfile changed
remote:        You have added to the Gemfile:
remote:        * rails (= 5.1.2)
remote:        * puma (= 3.9.1)
remote:        * sass-rails (= 5.0.6)
remote:        * uglifier (= 3.2.0)
remote:        * coffee-rails (= 4.2.2)
remote:        * jquery-rails (= 4.3.1)
remote:        * turbolinks (= 5.0.1)
remote:        * jbuilder (= 2.7.0)
remote:        * sqlite3 (= 1.3.13)
remote:        * byebug (= 9.0.6)
remote:        * web-console (= 3.5.1)
remote:        * listen (= 3.0.8)
remote:        * spring (= 2.0.2)
remote:        * spring-watcher-listen (= 2.0.1)
remote:        * pg (= 0.20.0)
remote:        You have deleted from the Gemfile:
remote:        * byebug
remote:        * capybara (~> 2.13)
remote:        * coffee-rails (~> 4.2)
remote:        * jbuilder (~> 2.5)
remote:        * listen (< 3.2, >= 3.0.5)
remote:        * puma (~> 3.7)
remote:        * rails (~> 5.1.2)
remote:        * sass-rails (~> 5.0)
remote:        * selenium-webdriver
remote:        * spring
remote:        * spring-watcher-listen (~> 2.0.0)
remote:        * sqlite3
remote:        * turbolinks (~> 5)
remote:        * uglifier (>= 1.3.0)
remote:        * web-console (>= 3.3.0)
remote:        Bundler Output: Warning: the running version of Bundler (1.15.2) is older than the version that created the lockfile (1.16.0.pre.2). We suggest you upgrade to the latest version of Bundler by running gem install bundler --pre.
remote:        You are trying to install in deployment mode after changing
remote:        your Gemfile. Run bundle install elsewhere and add the
remote:        updated Gemfile.lock to version control.
remote:        
remote:        The dependencies in your gemfile changed
remote:        
remote:        You have added to the Gemfile:
remote:        * rails (= 5.1.2)
remote:        * puma (= 3.9.1)
remote:        * sass-rails (= 5.0.6)
remote:        * uglifier (= 3.2.0)
remote:        * coffee-rails (= 4.2.2)
remote:        * jquery-rails (= 4.3.1)
remote:        * turbolinks (= 5.0.1)
remote:        * jbuilder (= 2.7.0)
remote:        * sqlite3 (= 1.3.13)
remote:        * byebug (= 9.0.6)
remote:        * web-console (= 3.5.1)
remote:        * listen (= 3.0.8)
remote:        * spring (= 2.0.2)
remote:        * spring-watcher-listen (= 2.0.1)
remote:        * pg (= 0.20.0)
remote:        
remote:        You have deleted from the Gemfile:
remote:        * byebug
remote:        * capybara (~> 2.13)
remote:        * coffee-rails (~> 4.2)
remote:        * jbuilder (~> 2.5)
remote:        * listen (< 3.2, >= 3.0.5)
remote:        * puma (~> 3.7)
remote:        * rails (~> 5.1.2)
remote:        * sass-rails (~> 5.0)
remote:        * selenium-webdriver
remote:        * spring
remote:        * spring-watcher-listen (~> 2.0.0)
remote:        * sqlite3
remote:        * turbolinks (~> 5)
remote:        * uglifier (>= 1.3.0)
remote:        * web-console (>= 3.3.0)
remote:  !
remote:  !     Failed to install gems via Bundler.
remote:  !
remote:  !     Push rejected, failed to compile Ruby app.
remote: 
remote:  !     Push failed
remote: Verifying deploy...
remote: 
remote: !       Push rejected to still-meadow-94689.
remote: 
To https://git.heroku.com/still-meadow-94689.git
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.heroku.com/still-meadow-94689.git'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

私の勘違いでした、デプロイは既に完了しており、herokuのurlを間違えている事が原因でした。
ご回答頂きありがとうございました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

checkベストアンサー

0

$ bundle install --without production
$ bundle update
$ git commit -a -m "Update gemfile.lock for heroku"
$ heroku create
$ git push heroic master

上記のように実行するとどうなりますか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/10/03 12:27

    ~/workspace/toy_app (master) $ bundle install --without production
    Using rake 12.1.0
    Using concurrent-ruby 1.0.5
    Using i18n 0.8.6
    Using minitest 5.10.3
    Using thread_safe 0.3.6
    Using tzinfo 1.2.3
    Using activesupport 5.1.2
    Using builder 3.2.3
    Using erubi 1.6.1
    Using mini_portile2 2.3.0
    Using nokogiri 1.8.1
    Using rails-dom-testing 2.0.3
    Using crass 1.0.2
    Using loofah 2.1.1
    Using rails-html-sanitizer 1.0.3
    Using actionview 5.1.2
    Using rack 2.0.3
    Using rack-test 0.6.3
    Using actionpack 5.1.2
    Using nio4r 2.1.0
    Using websocket-extensions 0.1.2
    Using websocket-driver 0.6.5
    Using actioncable 5.1.2
    Using globalid 0.4.0
    Using activejob 5.1.2
    Using mime-types-data 3.2016.0521
    Using mime-types 3.1
    Using mail 2.6.6
    Using actionmailer 5.1.2
    Using activemodel 5.1.2
    Using arel 8.0.0
    Using activerecord 5.1.2
    Using bindex 0.5.0
    Using bundler 1.16.0.pre.2
    Using byebug 9.0.6
    Using coffee-script-source 1.12.2
    Using execjs 2.7.0
    Using coffee-script 2.4.1
    Using method_source 0.9.0
    Using thor 0.20.0
    Using railties 5.1.2
    Using coffee-rails 4.2.2
    Using ffi 1.9.18
    Using multi_json 1.12.2
    Using jbuilder 2.7.0
    Using jquery-rails 4.3.1
    Using rb-fsevent 0.10.2
    Using rb-inotify 0.9.10
    Using listen 3.0.8
    Using puma 3.9.1
    Using sprockets 3.7.1
    Using sprockets-rails 3.2.1
    Using rails 5.1.2
    Using sass-listen 4.0.0
    Using sass 3.5.1
    Using tilt 2.0.8
    Using sass-rails 5.0.6
    Using spring 2.0.2
    Using spring-watcher-listen 2.0.1
    Using sqlite3 1.3.13
    Using turbolinks-source 5.0.3
    Using turbolinks 5.0.1
    Using uglifier 3.2.0
    Using web-console 3.5.1
    Bundle complete! 16 Gemfile dependencies, 64 gems now installed.
    Gems in the group production were not installed.
    Use `bundle info [gemname]` to see where a bundled gem is installed.
    :~/workspace/toy_app (master) $ bundle update
    The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
    Fetching gem metadata from https://rubygems.org/..........
    Fetching gem metadata from https://rubygems.org/...
    Fetching gem metadata from https://rubygems.org/..
    Resolving dependencies....
    Using rake 12.1.0
    Using concurrent-ruby 1.0.5
    Using i18n 0.8.6
    Using minitest 5.10.3
    Using thread_safe 0.3.6
    Using tzinfo 1.2.3
    Using activesupport 5.1.2
    Using builder 3.2.3
    Using erubi 1.6.1
    Using mini_portile2 2.3.0
    Using nokogiri 1.8.1
    Using rails-dom-testing 2.0.3
    Using crass 1.0.2
    Using loofah 2.1.1
    Using rails-html-sanitizer 1.0.3
    Using actionview 5.1.2
    Using rack 2.0.3
    Using rack-test 0.6.3
    Using actionpack 5.1.2
    Using nio4r 2.1.0
    Using websocket-extensions 0.1.2
    Using websocket-driver 0.6.5
    Using actioncable 5.1.2
    Using globalid 0.4.0
    Using activejob 5.1.2
    Using mime-types-data 3.2016.0521
    Using mime-types 3.1
    Using mail 2.6.6
    Using actionmailer 5.1.2
    Using activemodel 5.1.2
    Using arel 8.0.0
    Using activerecord 5.1.2
    Using bindex 0.5.0
    Using bundler 1.16.0.pre.2
    Using byebug 9.0.6
    Using coffee-script-source 1.12.2
    Using execjs 2.7.0
    Using coffee-script 2.4.1
    Using method_source 0.9.0
    Using thor 0.20.0
    Using railties 5.1.2
    Using coffee-rails 4.2.2
    Using ffi 1.9.18
    Using multi_json 1.12.2
    Using jbuilder 2.7.0
    Using jquery-rails 4.3.1
    Using rb-fsevent 0.10.2
    Using rb-inotify 0.9.10
    Using listen 3.0.8
    Using puma 3.9.1
    Using sprockets 3.7.1
    Using sprockets-rails 3.2.1
    Using rails 5.1.2
    Using sass-listen 4.0.0
    Using sass 3.5.1
    Using tilt 2.0.8
    Using sass-rails 5.0.6
    Using spring 2.0.2
    Using spring-watcher-listen 2.0.1
    Using sqlite3 1.3.13
    Using turbolinks-source 5.0.3
    Using turbolinks 5.0.1
    Using uglifier 3.2.0
    Using web-console 3.5.1
    Bundle updated!
    Gems in the group production were not installed.
    :~/workspace/toy_app (master) $ git commit -a -m "Update gemfile.lock for heroku"
    On branch master
    Your branch is ahead of 'origin/master' by 1 commit.
    (use "git push" to publish your local commits)

    nothing to commit, working tree clean
    :~/workspace/toy_app (master) $ heroku create
    Creating app... done, ⬢ blooming-basin-56355
    https://blooming-basin-56355.herokuapp.com/ | https://git.heroku.com/blooming-basin-56355.git
    ryolauren:~/workspace/toy_app (master) $ git push heroic master
    fatal: 'heroic' does not appear to be a git repository
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.
    :~/workspace/toy_app (master) $ git push heroku master
    Everything up-to-date
    :~/workspace/toy_app (master) $

    キャンセル

  • 2017/10/03 12:28

    上記の表に表示され、デプロイされない様です。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.99%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    6391questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6223questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。