質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Ruby

    7629questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • コマンド

    221questions

    コマンドとは特定のタスクを行う為に、コンピュータープログラムへ提示する指示文です。多くの場合、コマンドはShellやcmdようなコマンドラインインターフェイスに対する指示文を指します。

  • コマンドライン

    99questions

    コマンドライン(別名:Command Line Interface)は、ユーザに命令の入力を促す(プロンプト)文字列の表示を行い、すべての操作をキーボードを用いて文字列を打ち込む事でプログラムを走らせるユーザインターフェースです。

Rubyのバージョンを2.4.0にあげたい!

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 304

hatsu

score 110

rbenvを利用してrubyのバージョンを2.0.0から2.4.0にあげようとしています。

watarasebashi:~ username$ ruby -v
ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin16]


が現状です。
そしてrubyの2.4.0をインストールを行ったのが以下のコマンドです。

watarasebashi:~ username$ sudo env "PATH=$PATH" rbenv install
ruby-build: use openssl from homebrew
Downloading ruby-2.4.0.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.4/ruby-2.4.0.tar.bz2
Installing ruby-2.4.0...
ruby-build: use readline from homebrew

Installed ruby-2.4.0 to /Users/username/.rbenv/versions/2.4.0


しっかりとインストールがされたと思います。
しかし
rbenv versionsでインストールされているものを見ると

watarasebashi:~ username$ rbenv versions
rbenv: version `2.4.0' is not installed (set by /Users/username/.ruby-version)
  system


となっています。
パスが違うのが原因だと考えているのですが、ターミナルでのパスの設定などの知識があまりに乏しく、解決策が全くわかっておりません。

この問題の解決方法がわかる方、心当たりある方、些細なことでもいいのでご教授いただけると幸いです!
よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2017/09/30 18:07

    ターミナルで、「ls -l ~/.rbenv/versions/」で、何が表示されますか?

    キャンセル

  • hatsu

    2017/09/30 18:18

    CHERRY様回答ありがとうございます!上記コマンドを実行したところ、sudoをつけないとPermission deniedとなりました。sudoをつけて実行した結果はtotal 0 drwxr-xr-x 6 root staff 204 9 30 14:09 2.4.0となりました。

    キャンセル

回答 2

check解決した方法

0

https://teratail.com/questions/94624
の回答を持って解決いたしました。
回答してくださった方々、誠にありがとうございます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Permission denied が、発生しているため、username(ログインしているユーザアカウント) では、ruby を見つけられないのですね。

Permission denied になる原因はおそらく、rbenv install をsudo をつけて、実行しているから、ファイルオーナーが、username ではなく root になり、ファイルにアクセスできないためですね。

ファイルのオーナーを root から username(ログインしているユーザアカウント)に変更すると 修復できるのではないかとおもいます。(手元の環境では、 ログインユーザになっていました。)

ターミナルで、以下のコマンドを実行して、rbenv 関係ファイルのオーナーを username(ログインしているユーザアカウント)に変更してください。(usernameの部分を自分のアカウントに置き換えてください。)

sudo chown -R username:staff  ~/.rbenv/

なお、今後は、rbenv を実行する際は、sudo をつけずに実行するようにしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/30 22:24

    CHERRY様
    回答ありがとうございます!
    sudo chown -R *****:staff ~/.rbenv/
    を実行後、rbenv install 2.4.0を実行しました。
    すると以下のようになりまたエラーとなってしまいました。
    -------------------------------
    watarasebashi:~ username$ rbenv install 2.4.0
    ruby-build: use openssl from homebrew
    Downloading ruby-2.4.0.tar.bz2...
    -> https://cache.ruby-lang.org/pub/ruby/2.4/ruby-2.4.0.tar.bz2
    Installing ruby-2.4.0...
    mkdir: /Users/username/.rbenv/versions/2.4.0/lib: Permission denied

    BUILD FAILED (OS X 10.12.6 using ruby-build 20170914)

    Inspect or clean up the working tree at /var/folders/ly/x034db592mggs5krs73kr4zr0000gn/T/ruby-build.20170930214313.21819
    Results logged to /var/folders/ly/x034db592mggs5krs73kr4zr0000gn/T/ruby-build.20170930214313.21819.log

    Last 10 log lines:
    /var/folders/ly/x034db592mggs5krs73kr4zr0000gn/T/ruby-build.20170930214313.21819 ~
    /var/folders/ly/x034db592mggs5krs73kr4zr0000gn/T/ruby-build.20170930214313.21819/ruby-2.4.0 /var/folders/ly/x034db592mggs5krs73kr4zr0000gn/T/ruby-build.20170930214313.21819 ~
    rm: /Users/username/.rbenv/versions/2.4.0: Permission denied
    watarasebashi:~ username$ ls -l ~/.rbenv/versions
    ls: /Users/username/.rbenv/versions: Permission denied
    -------------------------------
    またPermission deniedとなっています。
    まだおそらく「ファイルのオーナーを root から username」が出来ていないのでしょうか?
    お手数かけますが、お時間あればご教授をお願いします。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.53%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7629questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • コマンド

    221questions

    コマンドとは特定のタスクを行う為に、コンピュータープログラムへ提示する指示文です。多くの場合、コマンドはShellやcmdようなコマンドラインインターフェイスに対する指示文を指します。

  • コマンドライン

    99questions

    コマンドライン(別名:Command Line Interface)は、ユーザに命令の入力を促す(プロンプト)文字列の表示を行い、すべての操作をキーボードを用いて文字列を打ち込む事でプログラムを走らせるユーザインターフェースです。