質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • Ruby

    7371questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2411questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

Homebrewのインストールについて

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 951

rata

score 1

Ruby及びRuby on Railsインストールのため、Homebrewをインストールしたいのですが、ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"をターミナルにて実行したところ、以下エラーが発生します。

/Users/ユーザーネーム/.rbenv/shims/ruby: line 21: /usr/local/Cellar/rbenv/0.4.0/libexec/rbenv: No such file or directory


また試しにbrew updateを実行したところ、以下エラーが発生しました。

/usr/local/bin/brew: /usr/local/Library/brew.rb: /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby: bad interpreter: No such file or directory
/usr/local/bin/brew: line 26: /usr/local/Library/brew.rb: Undefined error: 0

/System/Library/Frameworksディレクトリ内には、Ruby.frameworkが存在しません。


環境はOSX Yosemite 10.10.1です。
プログラミングを始めたばかりの初心者のため
言葉足らずな部分があるかと存じますが、何卒ご教示頂けます幸いです。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

YosemiteにはRuby1.8が搭載されていないようです。
Mac - Yosemiteでbrewが壊れた - Qiita

エラーメッセージに1.8が含まれていることから推測すると、上記URLの方法で解消する可能性が高そうです。
Rubyが動作するかどうかを確認するため、ターミナルでruby -vを実行してみていただけますか?


ただ、/System/Library/Frameworks/Ruby.frameworkが無いのは解せませんね。
私のはYosemite 10.10.2ですが、たぶん最初からあったと思います。
本当に無いのかどうか、ll -d /System/Library/Frameworks/Ruby.frameworkを実行して確認してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/05/07 22:35

    ご回答ありがとうございます。

    ruby -vを試したところ、以下の結果となりました。

    /Users/ユーザーネーム/.rbenv/shims/ruby: line 21: /usr/local/Cellar/rbenv/0.4.0/libexec/rbenv: No such file or directory


    また、ll -d /System/Library/Frameworks/Ruby.frameworkの結果も以下の通りです。

    -bash: ll: command not found


    どうにか解決しようとがちゃがちゃ触ってしまった結果、必要なファイルを消してしまった可能性が否めません。。

    ご提示頂きましたURLに関しても拝見させて頂きましたが、そもそもPC内にrubyが無い気がしています。

    お時間ある時で構いませんので、ご教示頂けますと幸いです。
    何卒宜しくお願い致します。

    キャンセル

  • 2015/05/07 22:39

    すみません、コマンドは ls -ld /System/Library/Frameworks/Ruby.framework
    でもう一度おねがいします。

    キャンセル

  • 2015/05/10 23:03

    遅れて申し訳御座いません。。

    この数日に知人に見て頂き、無事解決することが出来ました。
    アドバイス頂きまして本当にありがとうございました。

    また機会があった際には何卒宜しくお願い致します。

    キャンセル

0

誤投稿

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7371questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2411questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。