質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.03%

  • Python

    5512questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • OpenCV

    827questions

    OpenCV(オープンソースコンピュータービジョン)は、1999年にインテルが開発・公開したオープンソースのコンピュータビジョン向けのクロスプラットフォームライブラリです。

  • Raspberry Pi

    612questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。

opencvをpython3で使いたい

受付中

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 1,501

Keitana

score 2

Raspberry Pi 3 model Bにて

sudo apt-get install python-opencv

sudo apt-get install libopencv-dev

とopencvをインストールしたのですが、
python3(IDLE)で動かそうとすると

ImportError: No module named 'cv2'

となります。

python3上でcv2のモジュールを使えるようにするためソフトのインストール等によって可能でしょうか。
(インストールすべきソフトがあればご教示下さい!)
それとも、
python3でopencvを使いたい場合はcmakeを使ってビルドするしかないのでしょうか。

ご回答よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

僕も同じようにPython3からOpenCVを動かすのに苦労しました。
このリンク先のブログで解決したのですが、どうですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/15 23:26

    早速の回答ありがとうございます!
    皆さん苦労されるのですね

    試してみたのですが、Macと環境が違うようでうまく行きませんでした…
    PYTHONPATHの設定についても色々検索して試してみたのですが、
    知識不足でさっぱりでしたw

    キャンセル

0

pipでインストールすると簡単にできるかもしれないです。ブログからの引用です。

pip install opencv-contrib-python
引用ページ:OpenCV3.3(core+contrib)をPython3にpipで入れてみた

ちなみにpipはpythonのパッケージ管理ソフトで下記のようにインストールすることができます。

curl -O https://bootstrap.pypa.io/get-pip.py
引用ページ:Linux で Python、pip、EB CLI をインストールする

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/19 23:28

    回答ありがとうございます
    実行してみましたが

    pi@raspberrypi:~ $ python3 get-pip.py --user
    Requirement already up-to-date: pip in /usr/lib/python3/dist-packages

    pi@raspberrypi:~ $ py -3 -m pip install opencv-contrib-python
    bash: py: コマンドが見つかりません

    pi@raspberrypi:~ $ pip install opencv-contrib-python
    Collecting opencv-contrib-python
    Could not find a version that satisfies the requirement opencv-contrib-python (from versions: )
    No matching distribution found for opencv-contrib-python

    となり、駄目でした...

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 91.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    pipをインストールしたい

    pipのインストール方法がわからなくて困っております。 $ cat /proc/version Linux version 3.13.0-34-generic (buildd

  • 解決済

    PythonでOpenCVを使う

    前提・実現したいこと 動画から物体の検出、追跡を行う 発生している問題・エラーメッセージ 実行の際に以下のようなエラーが発生します。 ``` 2016-11-20 2

  • 解決済

    Linux - OpenCV VideoCaptureが動作しない

    環境 OS: ubuntu 16.04 LTS python 3.5.2 (Anaconda 2.5.0 64bit) opencv 3.1.0 (condaによる

  • 解決済

    python3+opencv3で人体検出をしたいのですが勉強方法がわかりません

    python3+opencv3で人体検出をしたいのですが勉強方法がわかりません。 おすすめの本、サイトなどございましたら教えていただきたいです。

  • 受付中

    python3.6.1でpipをインストールできない

    前提・実現したいこと Linux(Ubuntu64bit)でpython3.6.1を導入後にpipを導入をしようとしたところ以下のようなエラー文が返されました. 何を導入または修正

  • 解決済

    Raspberry piでOpenCVを利用したい

    前提・実現したいこと Raspberry pi 2でOpenCV(2.4.0)を利用できるように設定を行っているのですが、コンパイルでエラーが発生しました。 全くの初心者で解決方法

  • 解決済

    pip installでcv2をインストールできない

    前提・実現したいこと pythonでライブラリcv2のインポート 発生している問題・エラーメッセージ pythonでライブラリcv2をインポートしようとしましたがエラーが出まし

  • 解決済

    仮想環境でscrapingディレクトリが作成できない

    前提・実現したいこと とある本(Python クローリング&スクレイピング)に記載の通り、仮想環境でscrapingディレクトリを作成したいです。 解決策をご教示頂けますでしょうか

同じタグがついた質問を見る

  • Python

    5512questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • OpenCV

    827questions

    OpenCV(オープンソースコンピュータービジョン)は、1999年にインテルが開発・公開したオープンソースのコンピュータビジョン向けのクロスプラットフォームライブラリです。

  • Raspberry Pi

    612questions

    Raspberry Piは、ラズベリーパイ財団が開発した、名刺サイズのLinuxコンピュータです。 学校で基本的なコンピュータ科学の教育を促進することを意図しています。