質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.03%

phpモジュールがないので、cake3がうまく動作しません。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,506

iwasaki1112

score 5

[Cake\Database\Exception\MissingExtensionException] Database driver Cake\Database\Driver\Postgres cannot be used due to a missing PHP extension or unmet dependency


cakephpのerror.logで上記のようなエラーが出てしまって、うまく動作しません。
恐らく、postgresの拡張が入ってないと思い。

apt install postgresql
extension=php_pdo_pgsql.dll
extension=php_pgsql.dll


インストールし、php.ini内の上記2点のコメントアウトを解除し、apache再起動をかけましたが。
うまく行きませんでした。

どのように対処すればいいのか詳しい方教えていただけると助かります。
よろしくお願いいたします。

======= 追記 =======

イメージ説明

An Internal Error Has Occurredと画面上表示されます。

======= 追記 =======

スペックを下記に記載します。

Linux version 4.9.41-moby
PHP 5.6.28 (cli) (built: Nov 15 2016 00:38:35)
Loaded Configuration File    /usr/local/etc/php/php.ini

======= 追記 =======

Additional .ini files parsed

  • /usr/local/etc/php/conf.d/docker-php-ext-gd.ini,
  • /usr/local/etc/php/conf.d/docker-php-ext-mysqli.ini, 
  • /usr/local/etc/php/conf.d/docker-php-ext-opcache.ini, 
  • /usr/local/etc/php/conf.d/docker-php-ext-pdo_mysql.ini, 
  • /usr/local/etc/php/conf.d/docker-php-ext-zip.ini, 
  • /usr/local/etc/php/conf.d/opcache-recommended.ini
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2017/09/08 17:28

    app.phpのドライバーの向きはpostgresqlになっていますか?https://advanceffort.com/cakephp3%E3%81%A7postgresql%E3%81%AE%E8%A8%AD%E5%AE%9A/

    キャンセル

  • iwasaki1112

    2017/09/08 17:31

    mts10806さま こちらの設定はしておりますが、うまく動作しないんです。。

    キャンセル

回答 1

checkベストアンサー

+1

PostgreSQL はあっても、PHP の PDOモジュール(php-pgsql)が入っていないのではないでしょうか。

sudo apt list --installed php-pgsql


として、パッケージが表示されるでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/08 19:38

    上げられた ini ファイルの名前を見る限り、pgsql を読み込む設定がなされていないようです。
    Docker + PHP + PostgreSQL だと、 http://qiita.com/cyclon2joker/items/39e620d3d16fa1f6edf0 を参考に Docker コンテナを作り直したほうが良いかもしれません。

    キャンセル

  • 2017/09/08 19:41

    ありがとうございます。
    こちらを見ながらやってみます!

    キャンセル

  • 2017/09/11 20:05

    tacsheavenさま

    参考にいただいたqiitaの記事で無事うまくいきました!
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる