質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.98%

  • Laravel 5

    1454questions

    Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

laravelで、migrateを起動できない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 352

tidavest

score -106

~/sample$ php artisan migrate
PHP Warning:  require(/home/tide/sample/bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in /home/tide/sample/bootstrap/autoload.php on line 17
PHP Fatal error:  require(): Failed opening required '/home/tide/sample/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/tide/sample/bootstrap/autoload.php on line 17

コード

migrateに、限った話ではないと思うのですが、上記エラーです。
ディレクトリ構造が良くないのかもしれないと思っているのですが、homesteadをホームページのインストーラーより、インストールしたのですが、その後、laravelを
composer create-project laravel/laravel プロジェクト名
で、インストールしました。
どうすれば、上記エラーを解消できますでしょうか。


sample$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for phpunit/phpunit 4.8.20 -> satisfiable by phpunit/phpunit[4.8.20].
  • phpunit/phpunit 4.8.20 requires php ~5.3.3|~5.4|~5.5|~5.6 -> your PHP version (7.0.23) does not satisfy that requirement.

```
vendorディレクトリは、2つありましたが、sample直下になかったので、削除せず、composer updateを実行するも下記エラーです。
sample$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for phpunit/phpunit 4.8.20 -> satisfiable by phpunit/phpunit[4.8.20].
  • phpunit/phpunit 4.8.20 requires php ~5.3.3|~5.4|~5.5|~5.6 -> your PHP version (7.0.23) does not satisfy that requirement.

アドバイスお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2017/09/07 13:39

    どのようなコマンドを実行したら エラーが発生したのでしょうか?

    キャンセル

  • mts10806

    2017/09/07 13:47

    ざっくりで結構ですのでディレクトリ構成と、コマンドを実行した階層を追記してください。

    キャンセル

  • tidavest

    2017/09/18 22:35

    ありがとうございます。時間が経過したため、いったん閉じます。

    キャンセル

  • mts10806

    2017/09/19 13:28

    意味が分かりません。正しく解決したことを以て閉じるべきです。解決していないのに閉じるのは誰のためにもなりません。

    キャンセル

回答 1

checkベストアンサー

0

エラー内容を細かく書いてほしいです。バージョンも記載してください。

とりあえず、まずsampleディレクトリ内にあるvendorディレクトリを削除してください。

その後、composer installコマンドをsampleディレクトリ内で打ちます。

何かエラーが出たらそのエラーの内容を 質問本文 に追記してください。
何もエラーが出なかった場合は恐らく問題なく動作すると思います。(DBがそもそも無いとか.envが正しく設定されていないとかは置いといて)

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/08 20:00

    sample$ composer install
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    - Installation request for phpunit/phpunit 4.8.20 -> satisfiable by phpunit/phpunit[4.8.20].
    - phpunit/phpunit 4.8.20 requires ext-dom * -> the requested PHP extension dom is missing from your system.

    To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php/7.0/cli/php.ini
    - /etc/php/7.0/cli/conf.d/10-opcache.ini
    - /etc/php/7.0/cli/conf.d/10-pdo.ini
    - /etc/php/7.0/cli/conf.d/20-calendar.ini
    - /etc/php/7.0/cli/conf.d/20-ctype.ini
    - /etc/php/7.0/cli/conf.d/20-exif.ini
    - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.0/cli/conf.d/20-ftp.ini
    - /etc/php/7.0/cli/conf.d/20-gettext.ini
    - /etc/php/7.0/cli/conf.d/20-iconv.ini
    - /etc/php/7.0/cli/conf.d/20-json.ini
    - /etc/php/7.0/cli/conf.d/20-mbstring.ini
    - /etc/php/7.0/cli/conf.d/20-phar.ini
    - /etc/php/7.0/cli/conf.d/20-posix.ini
    - /etc/php/7.0/cli/conf.d/20-readline.ini
    - /etc/php/7.0/cli/conf.d/20-shmop.ini
    - /etc/php/7.0/cli/conf.d/20-sockets.ini
    - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
    You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

    キャンセル

  • 2017/09/08 20:01

    上記エラーです。アドバイスお願いいたします。

    キャンセル

  • 2017/09/08 20:07

    質問本文にと書いたのですが!

    sudo apt-get install php7.0-xmlrpc php7.0-xml
    試して再度vendorを消してcomposer installしてください

    キャンセル

  • 2017/09/08 20:27 編集

    composer update
    を行ってみてください。phpunit/phpunitのバージョンが古く、php7に対応していません。

    エラーを読めば分かる話だと思うのですが、エラーが出たからとりあえず貼るだけ貼るみたいな行為はしていませんよね?

    キャンセル

  • 2017/09/08 20:36

    update後、cd sample
    composer installを行いましたが、同じエラーでした。
    vendorディレクトリは、一つ増えましたが、sample直下のものではなかったので、削除しませんでした。

    キャンセル

  • 2017/09/08 20:38

    sample直下でcomposer updateしましたか?

    キャンセル

  • 2017/09/08 20:40

    sample$ composer update
    > php artisan clear-compiled
    PHP Warning: require(/home/tide/sample/bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in /home/tide/sample/bootstrap/autoload.php on line 17
    PHP Fatal error: require(): Failed opening required '/home/tide/sample/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php') in /home/tide/sample/bootstrap/autoload.php on line 17
    Script php artisan clear-compiled handling the pre-update-cmd event returned with error code 255
    上記エラーです。

    キャンセル

  • 2017/09/08 20:46 編集

    vendorディレクトリが作られる場所が何故かずれてしまったかなにか起きてますね。。。

    /home/tideの中にvendorディレクトリができてしまっていますか?
    もしもできてしまう場合は/home/tideにcomposer.jsonが無いか確認してください。もしある場合は削除してください。/home/tide/sampleのディレクトリ構成も崩れてしまっている可能性が大いに考えられるので、再度laravel newコマンドで作り直してください。

    キャンセル

  • 2017/09/18 22:35

    ありがとうございます。時間が経過したため、いったん閉じます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.98%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Laravel 5

    1454questions

    Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。