質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.09%

rails appのbundleがインストールできない

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,492
bundle install
Fetching gem metadata from https://rubygems.org/.........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Using rake 12.0.0
Using concurrent-ruby 1.0.5
Using i18n 0.8.6
Using minitest 5.10.3
Using thread_safe 0.3.6
Using builder 3.2.3
Using erubi 1.6.1
Using mini_portile2 2.2.0
Using rack 2.0.3
Using nio4r 2.1.0
Using websocket-extensions 0.1.2
Using mime-types-data 3.2016.0521
Using arel 8.0.0
Using public_suffix 2.0.5
Using bcrypt 3.1.11
Using bindex 0.5.0
Using bundler 1.15.4
Using byebug 9.0.6
Using mini_mime 0.1.3
Using ffi 1.9.18
Using coffee-script-source 1.12.2
Using execjs 2.7.0
Using method_source 0.8.2
Using thor 0.19.4
Using orm_adapter 0.5.0
Using multi_json 1.12.1
Using rb-fsevent 0.10.2
Using ruby_dep 1.5.0
Fetching pg 0.21.0
Installing pg 0.21.0 with native extensions
Fetching puma 3.9.1
Installing puma 3.9.1 with native extensions
Using rubyzip 1.2.1
Using tilt 2.0.8
Using turbolinks-source 5.0.3
Using tzinfo 1.2.3
Using nokogiri 1.8.0
Using rack-test 0.6.3
Using warden 1.2.7
Using sprockets 3.7.1
Using websocket-driver 0.6.5
Using mime-types 3.1
Using addressable 2.5.1
Using childprocess 0.7.1
Using rb-inotify 0.9.10
Using coffee-script 2.4.1
Using uglifier 3.2.0
Errno::EACCES: Permission denied @ rb_sysopen -
/Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/pg-0.21.0/.gemtest
An error occurred while installing pg (0.21.0), and Bundler cannot
continue.
Make sure that `gem install pg -v '0.21.0'` succeeds before bundling.

In Gemfile:
  pg

となります。この

Errno::EACCES: Permission denied @ rb_sysopen -
/Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/pg-0.21.0/.gemtest
An error occurred while installing pg (0.21.0), and Bundler cannot
continue.
Make sure that `gem install pg -v '0.21.0'` succeeds before bundling.

このエラーが解決できません。

gem install pg -v '0.21.0'

を実行すると

    Permission denied @ rb_sysopen - /Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/pg-0.21.0/.gemtest

となります。

chmod 777 /Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/

をやってからもう一度やっても変わらず。

どうすれば解決できますか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

sudo付けてもダメですか?
とはいえsudoで解決したとしても今後もった別のgemのインストールでPermission deniedが起こると思います。

そもそもrbenvでrubyの切り替えがうまくいっていないのでは?
rbenvの再インストールをおすすめします。

macでgem install railsを実行するとPermission deniedを吐かれた

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/09/01 09:59

    一度rbenvをデリートしてインストールし直したのですが変化ありませんでした。

    sudoもつけてみましたが変わりません。。。。

    キャンセル

  • 2017/09/01 11:09

    こういうのを見つけました
    http://easyramble.com/bundle-install-pg-error.html
    環境がLinuxかMacのHomebrewかわかりませんが、
    先にpostgresqlをインストールしてみては。

    キャンセル

0

chmod 777 /Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/

だと、~/.rbenv/versions/2.4.1/lib/rubyディレクトリしか変更されません。

Permission denied @ rb_sysopen - /Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/pg-0.21.0/.gemtest

なので、

chmod 777 /Users/watanabetakushin/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/pg-0.21.0/.gemtest


とすれば、エラーに対するこのエラー自体は無くなるでしょう。しかし、~/.rbenv/versions/2.4.1/lib/ruby以下のパーミッションがおかしくなっている根本的な解決にはならないと想像してます。そのディレクトリ以下を再帰的に変更する必要があります。

ls -lR ~/.rbenv/versions/2.4.1/lib/rubyなどとして、まずはパーミッションやファイル所有者を確認した方が良いでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.09%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる