質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.10%

Google play開発者サービスの更新が必要と出てくる

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,141

score 7

現在、Android Studioを使って地図を表示させるアプリを作っているのですが、build.gradleで
compile 'com.google.android.gms:play-services:+'
とするとアプリ起動時にGoogle play開発者サービスの更新が必要と出てきます。
'+'の部分を様々なバージョンに変えてみたところMainActivityの方でのimport文にエラーが出てきてしまいます。
バージョンを何にすればimport文にエラーが起きずに地図を表示できるか教えてください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • maisumakun

    2017/08/21 16:05

    Google play開発者サービスを一度更新しても起動のたびに更新メッセージが出てくる、ということでしょうか。

    キャンセル

  • kab0718

    2017/08/21 16:12

    そうです

    キャンセル

  • aja

    2017/08/22 00:20 編集

    コードが無いですね。com.google.android.gms:play-servicesは適切に設定しないといけない、というエラーがでているのではないでしょうか

    キャンセル

回答 1

checkベストアンサー

0

こちらを参考にしているということを前提とすれば
https://akira-watson.com/android/fusedlocationproviderapi.html

gradleバージョンをそのまま変更せずに
ワーニングが出ても気にせず実行すればできるようです

ただ、現行のAndroid Studio 2.3.3であれば
以下のような変更が必要です

compile 'com.google.android.gms:play-services:+'
は個別に分けるようになりましたので
位置情報取得であればlocation, 地図はmapです

build.gradle

android {
    compileSdkVersion 26
    buildToolsVersion "26.0.1"
...
}

...

dependencies {
...

    compile 'com.android.support:appcompat-v7:26.0.0-alpha1'
    compile 'com.google.android.gms:play-services-location:11.0.4'
    compile 'com.google.android.gms:play-services-maps:11.0.4'
...
}

この辺りのライブラリーバージョンは
Android Studio 3.0から変わると思われるので
今だけの設定かもしれません

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る