質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

ciscoのvlan間pingでのパケット重複の解消

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,986

score 13

こんにちは、GNS3を使って構築したネットワークについて質問です。
現在勉強のため、以下のようなネットワークを構築しました。
ESW1とECW2はCisco3725にNM-16ESWを入れてL3スイッチ化したものです。
ESW1とESW2はEtherChannelで二つの物理ポートを束ねたtrunkポートで繋いでいます。
trunkポートではVLAN10とVLAN20の通信を許可しています。
CentOSマシン間でのping疎通はすべて成功しています。

イメージ説明

しかし、CentOS7-1からCentOS7-3にPingを送信すると、
Duplicate Replyになってしまいます。

通信内容を確認すると、Pingリクエストが
・CentOS7-1 → ESW1 → CentOS7-3
の経路で届いているものと、
・CentOS7-1 → ESW1 → ESW2 → ESW1 → CentOS7-3
という経路で届いているものの二つがあり、
結果としてPingが二つReplyされている状況のようです。

このとき、ESW1かESW2で通信の重複を抑える方法が知りたいのですが、
調べてもいまいちやり方がわかりません。
ご存知の方おられましたらご回答お願いいたします。

=========
ご回答に対して
少し長くなりますが、、ESW1とESW2のshow run結果について添付します、

#############ESW1###############
!
!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
@
macro name del_vlan
end
vlan database
no vlan $v
exit
@
!
vtp file nvram:vlan.dat
archive
 log config
  hidekeys
! 
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Port-channel1
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
!
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport access vlan 10
 duplex full
 speed 100
!
interface FastEthernet1/1
 switchport access vlan 20
 duplex full
 speed 100
!
interface FastEthernet1/2
 duplex full
 speed 100
!
interface FastEthernet1/3
 duplex full
 speed 100
!
interface FastEthernet1/4
 duplex full
 speed 100
!
interface FastEthernet1/5
 duplex full
 speed 100
!
interface FastEthernet1/6
 duplex full
 speed 100
!
interface FastEthernet1/7
 duplex full
 speed 100
!
interface FastEthernet1/8
 duplex full
 speed 100
!
interface FastEthernet1/9
 duplex full
 speed 100
!
interface FastEthernet1/10
 duplex full
 speed 100
!
interface FastEthernet1/11
 duplex full
 speed 100
!
interface FastEthernet1/12
 duplex full
 speed 100
!
interface FastEthernet1/13
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/14
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/15
 description ### administration ###
 switchport access vlan 2
 duplex full
 speed 100
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description ### administration ###
 ip address 192.168.11.51 255.255.255.0
!
interface Vlan10
 description ### test vlan #1 ###
 ip address 192.168.100.1 255.255.255.0
!
interface Vlan20
 description ### test vlan #2 ###
 ip address 192.168.101.1 255.255.255.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.51.1
ip route 0.0.0.0 0.0.0.0 192.168.11.1
ip route 0.0.0.0 0.0.0.0 192.168.11.2
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner exec 

***************************************************************
This is a normal Router with a Switch module inside (NM-16ESW)
It has been pre-configured with hard-coded speed and duplex

To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Alias(exec)     : vl   - "show vlan-switch brief" command
Alias(configure): va X - macro to add vlan X
Alias(configure): vd X - macro to delete vlan X
***************************************************************


alias configure va macro global trace add_vlan $v
alias configure vd macro global trace del_vlan $v
alias exec vl show vlan-switch brief
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password *****
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 password ******
 login
!
!
end
###########ESW2##############
!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
@
macro name del_vlan
end
vlan database
no vlan $v
exit
@
!
vtp file nvram:vlan.dat
archive
 log config
  hidekeys
! 
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Port-channel1
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
!
interface FastEthernet0/0
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description *** Unused for Layer2 EtherSwitch ***
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport access vlan 10
 duplex full
 speed 100
!
interface FastEthernet1/1
 duplex full
 speed 100
!
interface FastEthernet1/2
 duplex full
 speed 100
!
interface FastEthernet1/3
 duplex full
 speed 100
!
interface FastEthernet1/4
 duplex full
 speed 100
!
interface FastEthernet1/5
 duplex full
 speed 100
!
interface FastEthernet1/6
 duplex full
 speed 100
!
interface FastEthernet1/7
 duplex full
 speed 100
!
interface FastEthernet1/8
 duplex full
 speed 100
!
interface FastEthernet1/9
 duplex full
 speed 100
!
interface FastEthernet1/10
 duplex full
 speed 100
!
interface FastEthernet1/11
 duplex full
 speed 100
!
interface FastEthernet1/12
 duplex full
 speed 100
!
interface FastEthernet1/13
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/14
 switchport trunk allowed vlan 1,10,20,1002-1005
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/15
 description ### administration ###
 switchport access vlan 2
 duplex full
 speed 100
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description ### administration ###
 ip address 192.168.11.52 255.255.255.0
!
interface Vlan10
 description ### test vlan #1 ###
 ip address 192.168.100.11 255.255.255.0
!
interface Vlan20
 description ### test vlan #2 ###
 ip address 192.168.101.11 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
banner exec 

***************************************************************
This is a normal Router with a Switch module inside (NM-16ESW)
It has been pre-configured with hard-coded speed and duplex

To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config

To view existing vlans use the command "show vlan-switch brief"

Alias(exec)     : vl   - "show vlan-switch brief" command
Alias(configure): va X - macro to add vlan X
Alias(configure): vd X - macro to delete vlan X
***************************************************************


alias configure va macro global trace add_vlan $v
alias configure vd macro global trace del_vlan $v
alias exec vl show vlan-switch brief
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password ******
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 password *******
 login
!
!
end
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

まず、ESW1とESW2(とサーバ1とサーバ2)が192.168.100.*のLANに属しているというのが気になります。

とりあえずshow ip routeとかshow runでルーティングテーブルやインタフェースのIPアドレスを詳しく知りたいです。(主にESW1と2)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/20 23:38

    show run結果について追記しました。

    以上よろしくお願いします。

    キャンセル

  • 2017/08/21 00:39

    追記ありがとうございます。
    設定見ましたが、ちょっと自分もこれだけだとわからないです。まあ、この構成だとESW2についてはVLAN20に属する必要がないので、これを削除すれば可能性もあるとは思います。が、確証なし+構成変更すると対応できないといったことがあります。

    キャンセル

  • 2017/08/21 12:34

    この構成においてspanning-treeの設定必要ないのでしょうか?GNS3なるものを良く理解していないので自信がないのですが、物理スイッチ構成であればspanning-tree設定は必須だと思っています。

    キャンセル

  • 2017/08/23 22:39

    HogeAnimalLoverさん
    PingReplyの重複ですが、時間が経つと解消されました。Dynamips側のエミュレートが良くなかったのかもしれません。回答に時間をかけていただいた後で申し訳ないのですが、

    overさん
    stpはESW1とESW2で(暗黙的に)ONになっているようです。


    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る