質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.06%

SQLSTATE[HY000][1049]

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,070

yuus2733

score 111

https://laravel10.wordpress.com/2015/02/25/%E5%88%9D%E3%82%81%E3%81%A6%E3%81%AElaravel-5-6-%E3%83%9E%E3%82%A4%E3%82%B0%E3%83%AC%E3%83%BC%E3%82%B7%E3%83%A7%E3%83%B3%E3%81%A7db%E3%81%AE%E3%83%90%E3%83%BC%E3%82%B8%E3%83%A7%E3%83%B3%E7%AE%A1/
こちらのサイトを参考にLaravelの学習をしています。
前回の質問に関することは自己解決できました。
ですが今度は下記のmigrateを実行した際にタイトルのエラーが出ました。
.envもdatabase.phpも前回の質問で書き換えてあるのに
[forge]というテーブルがあるか探しに行っているようです。
sqlsrvという区画を参照しているのでしょうか・・・
何故こうなるのかがわかりません・・・ご教示ください。

migrate実行

C:\xampp\htdocs\laravel>php artisan migrate
**************************************
*     Application In Production!     *
**************************************

Do you really wish to run this command? y


  [PDOException]
  SQLSTATE[HY000] [1049] Unknown database 'forge'


migrate [--bench [BENCH]] [--database [DATABASE]] [--force] [--path [PATH]] [--p
ackage [PACKAGE]] [--pretend] [--seed]

.env

APP_NAME=Laravel
APP_ENV=local
APP_KEY=base64:eqUQ0WTmJWsutQBJhYPQ7CqxsY6pukKXmLMQ0U+oYIo=
APP_DEBUG=true
APP_LOG_LEVEL=debug
APP_URL=http://localhost

DB_CONNECTION=sqlite
DB_HOST=localhost
DB_PORT=3306
DB_DATABASE=mysql
DB_USERNAME=pma
DB_PASSWORD=
DB_SOCKET=/Applications/XAMMP/xammpfiles/var/mysql/mysql.sock

BROADCAST_DRIVER=log
CACHE_DRIVER=file
SESSION_DRIVER=file
QUEUE_DRIVER=sync

REDIS_HOST=127.0.0.1
REDIS_PASSWORD=null
REDIS_PORT=6379

MAIL_DRIVER=smtp
MAIL_HOST=smtp.mailtrap.io
MAIL_PORT=2525
MAIL_USERNAME=null
MAIL_PASSWORD=null
MAIL_ENCRYPTION=null

PUSHER_APP_ID=
PUSHER_APP_KEY=
PUSHER_APP_SECRET=

database.php

    'default' => env('DB_CONNECTION', 'mysql'),

    /*
    |--------------------------------------------------------------------------
    | Database Connections
    |--------------------------------------------------------------------------
    |
    | Here are each of the database connections setup for your application.
    | Of course, examples of configuring each database platform that is
    | supported by Laravel is shown below to make development simple.
    |
    |
    | All database work in Laravel is done through the PHP PDO facilities
    | so make sure you have the driver for your particular database of
    | choice installed on your machine before you begin development.
    |
    */

    'connections' => [

        'sqlite' => [
            'driver' => 'sqlite',
            'database' => storage_path('database.sqlite'),
            'prefix' => '',
        ],

        'mysql' => [
            'driver' => 'mysql',

            'host' => env('DB_HOST', 'localhost'),
            'port' => env('DB_PORT', '3306'),
            'database' => env('DB_DATABASE', 'mysql'),
            'username' => env('DB_USERNAME', 'pma'),
            'password' => env('DB_PASSWORD', ''),
            'unix_socket' => env('DB_SOCKET', null),
            'charset' => 'utf8mb4',
            'collation' => 'utf8mb4_unicode_ci',
            'prefix' => '',
            'strict' => false,
            'engine' => null,
        ],

        'pgsql' => [
            'driver' => 'pgsql',
            'host' => env('DB_HOST', 'localhost'),
            'port' => env('DB_PORT', '5432'),
            'database' => env('DB_DATABASE', 'mysql'),
            'username' => env('DB_USERNAME', 'pma'),
            'password' => env('DB_PASSWORD', ''),
            'charset' => 'utf8',
            'prefix' => '',
            'schema' => 'public',
            'sslmode' => 'prefer',
        ],

        'sqlsrv' => [
            'driver' => 'sqlsrv',
            'host' => env('DB_HOST', 'localhost'),
            'port' => env('DB_PORT', '1433'),
            'database' => env('DB_DATABASE', 'forge'),
            'username' => env('DB_USERNAME', 'forge'),
            'password' => env('DB_PASSWORD', ''),
            'charset' => 'utf8',
            'prefix' => '',
        ],

    ],

    /*
    |--------------------------------------------------------------------------
    | Migration Repository Table
    |--------------------------------------------------------------------------
    |
    | This table keeps track of all the migrations that have already run for
    | your application. Using this information, we can determine which of
    | the migrations on disk haven't actually been run in the database.
    |
    */

    'migrations' => 'migrations',
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • aro10

    2017/08/18 19:34 編集

    コードのdatabase.phpと.envが同じものになっているみたいです

    キャンセル

  • yuus2733

    2017/08/18 19:50

    申し訳ないです、修正しました。

    キャンセル

回答 1

checkベストアンサー

+1

WindowsのXAMPで開発している想定で、.envの情報が反映されない場合は、.envの反映先はWebサーバーの環境変数なので一度Webサーバー(Apache)を再起動してみてください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/19 10:02

    vagrant1.9.4を使ってドットインストール視聴と実践をしていたのが5月頃なのですが、その時にダウンロードしたインストーラーを履歴削除でけしてしまったので今1.9.7のインストールもできなくて困ってます…
    (1.9.4のアンインストールにも1.9.7のインストールにも消してしまったインストーラを要求されてます)

    キャンセル

  • 2017/08/19 16:28

    Windowsを使っていないので履歴削除というのがピンとこないですが、ここからWindows用のmsiインストーラをダウンロードして実行してもだめなのでしょうか
    https://www.vagrantup.com/downloads.html

    キャンセル

  • 2017/08/19 18:16

    公式の物だと1.9.7しかダウンロードできなくてできませんでした、
    けど、過去のバージョンのインストーラをあげてくれている場所があってそこからダウンロードしてできました!(すごくリスキーでしたが…)

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る