質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.94%

iOS SDKのバージョンによる違いについて

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 8,013

score 155

当方、iOSアプリの開発をしたことがありませんが既存アプリの改修をすることとなりました。
iOS SDKのバージョンのごとの違いがあまりわかっていません。

  1. 使用するiOS SDKのバージョンによりiOSの最低動作バージョンが変わる?  
    wikiから見るにXcode 8についている iOS SDKの場合はiOS 10が最低動作バージョンになるのでしょうか?

  2. Xcode 8についている iOS SDKを使用する場合はiOS 10以降は動作すると思ってよろしいのでしょうか?

  3. Xcode 8.3.3にについている iOS SDKを使用する場合はiOS 10は動作対象外となってしまうのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

  1. SDKは対応するバージョンのOSで動くアプリを開発するためのものなので、新しいバージョンのiOSが出るとそれに追加/変更/削除された機能に追従するようにSDKもリリースされます。
    といっても、完全にリプレースされることはまずないので、変わったところを全く使わなければ新しいSDKを使用したアプリはそれ以前のiOS上でも大抵動きます。ですので、iOS10向けのSDKを使って開発したアプリが、iOS9が持っていてiOS10で全く変更されていない機能しか使っていないならiOS9でも動きます。

  2. 1の通り普通動きますが、今後ずっとという保証はありません。iOS6->7のように大きな変更があってうまく動かないというのはありえます。特にAppleは良く動作を変えるので特定の機能がAppleの胸三寸で動かなくなることもあります。

  3. これも1の通りで対象外にはならないです。

使用するSDKと最低動作バージョンはそれぞれアプリのプロジェクト設定で変更することができます。
SDKには各機能ごとに追加されたり使用非推奨となったバージョンが記載されていてプロジェクトで設定されたバージョンが範囲外の場合はビルド時に警告を出してくれます。
また、機能が削除された場合はSDKにその機能がないということなのでビルドは通りません。
一度ビルドしてみて特に警告が無かったら大抵動きますよ。
画面レイアウトが崩れるなどは別問題ですが。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/10 13:29

    回答ありがとうございます。
    以下のような解釈であっていますでしょうか?
    - iOS 10 SDKを使用する場合でもiOS 10未満及び以降のiOSでも動作するが、SDKの変更内容によっては機能がなくなってしまうことがあるのでその場合はビルドが通らなくなるのでそれで確認することができる。

    例えば、iOS9SDKで開発した既存のアプリをiOS11に対応させたいという場合は、iOS11SDKを内包しているXcodeを使用し、ビルドしてエラーになった箇所を修正するみたいな感じになるのでしょうか

    キャンセル

  • 2017/08/10 14:21

    解釈はそれであっています。まぁ下位互換性がなくなるので機能が無くなるのはそんなにありませんけど。
    「対応させたい」というのは色々含みますがやり方はそうです。
    まず現行のアプリをiOS11で動かしてみて、

    1. iOSのバージョンを変えても特に全機能問題なく動く
      -> 現行から変更する必要は無い
    2. あるバージョン以降のiOSで特定の機能を使おうとしたらクラッシュしたり何かうまく動かない
      -> iOSの機能が置き換わっていたり動作変更があったりしないか調べてそれに合わせる
    3.起動しない
      -> 例えばiOS11だったら64bitが必須になるので32bitアプリは起動しなくなる
        この場合は設定を変えてビルドしなおし動作を再確認する
    4.そもそもビルドが通らない
      -> 機能が削除されたりビルド時にわかるような変更の恐れあり、ビルドエラーを調べる

    といったことをします。
    そのあとiOS11特有の機能を追加対応したいなら機能を使う前にiOSのバージョンを調べて対応有無を判定するようなプログラムにします。

    キャンセル

0

Q1. 使用するiOS SDKのバージョンによりiOSの最低動作バージョンが変わる?  
A1. 逆です、最新のSDKバージョンを使うと最新版のiOSへの最適化及び最新版のiOSの新機能が利用できるようになります。逆に最低動作バージョンはXcodeのDeployment Targetの方で設定されます(Xcode 8の場合は選択できる最低バージョンはiOS 8になります)

Q2. Xcode 8についている iOS SDKを使用する場合はiOS 10以降は動作すると思ってよろしいのでしょうか?
A2. 「iOS 10以降でしか動作しない」という意図の質問でしたら、A1で述べた通り違います。「iOS 10以降(iOS 11とか)でも動作する」という意図の質問でしたら、答えは「9割9分問題ない」となります。稀に動作しなくなることもあります。

Q3. Xcode 8.3.3にについている iOS SDKを使用する場合はiOS 10は動作対象外となってしまうのでしょうか?
A3. 「iOS 10.0」という意味でしたら、Deployment TargetがiOS 10.0もしくはそれ以前であれば動作します。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/08/10 13:20

    回答ありがとうございます。
    以下のような解釈であっていますでしょうか?
    - 最低動作バージョンはDeployment Targetで設定(選択)でき、その範囲はXcode自体のバージョンによる。
    - iOS 10 SDKを使用する場合でもiOS 10未満も基本的に動作するし、iOS 11以降でもほぼ動作するはず。

    キャンセル

  • 2017/08/10 13:29

    - 最低動作バージョンはDeployment Targetで設定(選択)でき、その範囲はXcode自体のバージョンによる。
    だいたいそうです。ただDeployment Targetは選択できないバージョンでも無理やり手入力でできなくはないです(オススメはしませんが)

    - iOS 10 SDKを使用する場合でもiOS 10未満も基本的に動作するし、iOS 11以降でもほぼ動作するはず。
    はい、そうです

    キャンセル

  • 2017/08/10 14:57

    えるたそー 横から失礼。

    内容は古いが、要件は変わっていない。
    SDK互換性ガイド
    https://developer.apple.com/jp/documentation/cross_development.pdf

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.94%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る