質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

プロジェクトのbuild.gradleにcom.google.gms:google-services:3.0.0を加えるとBuildできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 12K+

gittib_gittib

score 98

前提・実現したいこと

最近 Android Studio をアップデートしたのですが、それ以来プロジェクトのbuild.gradle に google-services を加えると
org.gradle.tooling.BuildException が発生してビルドができません。そのエラーを解消し、ビルドできるようにしたいです。

発生している問題・エラーメッセージ

https://jcenter.bintray.comへのSSL通信に失敗しているようです。
スタックトレースをそのまま載せてしまうと400行以上になるので、1行目及び「Caused by:」で始まる行のみを以下に示します。

org.gradle.tooling.BuildException: Could not run build action using Gradle distribution 'https://services.gradle.org/distributions/gradle-3.3-all.zip'.
Caused by: org.gradle.internal.exceptions.LocationAwareException: A problem occurred configuring root project 'MyApplication'.
Caused by: org.gradle.api.ProjectConfigurationException: A problem occurred configuring root project 'MyApplication'.
Caused by: org.gradle.api.artifacts.ResolveException: Could not resolve all dependencies for configuration ':classpath'.
Caused by: org.gradle.internal.resolve.ModuleVersionResolveException: Could not resolve com.google.gms:google-services:3.0.0.
Caused by: org.gradle.internal.resolve.ModuleVersionResolveException: Could not resolve com.google.gms:google-services:3.0.0.
Caused by: org.gradle.api.resources.ResourceException: Could not get resource 'https://jcenter.bintray.com/com/google/gms/google-services/3.0.0/google-services-3.0.0.pom'.
Caused by: org.gradle.internal.resource.transport.http.HttpRequestException: Could not HEAD 'https://jcenter.bintray.com/com/google/gms/google-services/3.0.0/google-services-3.0.0.pom'.
Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

該当のソースコード

エラーの原因と思われる、プロジェクトのbuild.gradleを以下に示します。
com.google.gms:google-services:3.0.0を追加しているだけです。

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'
        classpath 'com.google.gms:google-services:3.0.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

試したこと

一応、jcenterにhttpsでなくhttpでつなぐと正常にビルド~アプリ実行までできました。
その時のbuild.gradleを以下に示します。

buildscript {
    repositories {
        jcenter {
            url "http://jcenter.bintray.com"
        }
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'
        classpath 'com.google.gms:google-services:3.0.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter {
            url "http://jcenter.bintray.com"
        }
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}


ただ、今までSSLで繋いでいたところを、いたずらにhttpで繋ぐのはいかがなものかと思うので、jcenterのurlをいじらずに繋ぎたいと思っています。

補足情報(言語/FW/ツール等のバージョンなど)

「classpath 'com.google.gms:google-services:3.0.0'」の記述を削除してもビルドは通りました。
ただ、要件的にgoogle-servicesは必須なのでエラーなく読み込みたいです。

  • Android Studio のバージョン: 2.3
  • distributionUrl=https://services.gradle.org/distributions/gradle-3.3-all.zip
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • ahodana

    2017/07/24 19:25

    そのバージョンは公開されてるのか?

    キャンセル

  • gittib_gittib

    2017/07/24 19:33

    com.google.gms:google-services:3.0.0が公開されているか?という質問でしたら、公開されていると認識しています。以前にも https://firebase.google.com/docs/android/setup?hl=ja を参考に上記クラスパスを追加したプロジェクトを開発していて、その時はビルドできていました。Android Studioのアップデートが引き金になっていると睨んでいますが、確証はありません。

    キャンセル

回答 1

check解決した方法

0

一旦、エラーは解消できたので、自己解決とさせていただきます。

原因は、Android Studio が指定するJDKがbintray.comの証明書を信頼していないためでした。
よって、以下のように対応しました。

  • 各種ブラウザでhttps://jcener.bintray.comが信頼された証明書で通信できることを確認した上で、当該サイトから証明書をダウンロード
  • Android Studio にて、メニューの「File」→「Project Structure...」を開き、「SDK Location」を確認
  • 「JDK location:」を確認し、必要に応じて使用するJDKを指定
  • keytool を使って %JDKlocation%\jre\lib\security\cacerts を確認し、ダウンロードした証明書をインポート
    参考にしたサイト

とりあえずこれでビルドが通るようになりました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる