質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.83%

Azure Web APP から SQL データベースへの接続について(Entity Framework利用)

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 3,339

taki2017

score 10

前提・実現したいこと

C#.NETでWebサイトを開発しております。Entity FrameworkのコードファーストでDBを操作。
最終的にはAzureWebAppで公開を目標にしております。

発生している問題・エラーメッセージ

ローカルVisualStudioでのデバッグ時はローカルDBを利用していたのですが、
いざAzurede動作させようと、VisualStudioからAzureのWebAppに発行する際
プロファイルを新規作成し、SQLデータベースを構築。接続するようデプロイしたのですが、
下記エラーが発生し、ページが表示できません。

原因と解決について分かる方教えて頂けますでしょうか。

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

web.config接続文字列

Data Source=tcp:hoge1.database.windows.net,1433;Initial Catalog=hoge_db;User Id=hoge2@hoge;Password=hoge3

試したこと

・web.configのentityFrameworkの記述はコメントアウト済
・SQLデータベースのファイヤーウォールにクライアントIPを追加
・ローカル端末からSQLServerManagementStudioを使用してAzureSQLデータベースへは接続確認済
・Azure管理ポータルWebAppの「データ接続」項目には作成したDBの記述を確認
・ローカルVisualStudioデバッグ時にAzureSqlデータベースへ接続しようとすると、DB接続ロジック部で同じエラーが発生しブレークする。

どうぞよろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • SurferOnWww

    2017/06/16 18:33

    Web は何ですか? .NET Framework ベースの ASP.NET MVC5 ?

    キャンセル

  • taki2017

    2017/06/19 09:17

    はい、MVC5で、,netframeWorkは 4.5です

    キャンセル

回答 3

check解決した方法

+1

解決しました。方法は以下の通りです。

VisualStudioプロジェクトを公開する際の「発行」画面にある
サイトURLの設定リンクをクリックし、続けて左部の「設定」を選択
データベース欄のContextクラスごとの「リモート接続」に接続文字列を入力することで
Webアプリが表示されました。

ご回答くださった方ありがとうございました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

こんにちは。

Azure管理ポータルWebAppの「データ接続」項目には作成したDBの記述を確認

データ接続ってなんでしたっけ…。
App Service - アプリケーション設定 - 接続文字列
には正しい接続文字列は設定されていますか?

SQLデータベースのファイヤーウォール設定でAzureサービスからの接続は許可されていますか?

Visual Studio からデプロイする際にSQL Databaseを指定した上で接続テストが行えると思いますが、そこでは成功しているのでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/20 17:01

    >App Service - アプリケーション設定 - 接続文字列
    ```
    Data Source=tcp:[Server].database.windows.net,1433;Initial Catalog=[Database];User Id=[User]@[Server];Password=[PW];

    Server=tcp:[Server].database.windows.net,1433;Database=[Database];User Id=[User]@[Server];Password=[PW];Trusted_Connection=False;Encrypt=True;
    ```
    ありがとうございます。
    上記の通り変更してみましたが、結果は変わらずでした。

    >SQLデータベースのファイヤーウォール設定でAzureサービスからの接続は許可されていますか?
    ファイヤーウォール設定の「Azure サービスへのアクセスを許可」をオンにしております。

    >Visual Studio からデプロイする際にSQL Databaseを指定した上で接続テストが行えると思いますが、そこでは成功しているのでしょうか。

    こちら、接続テストの方法を教えていただけますでしょうか。
    よろしくお願いします。

    キャンセル

  • 2017/06/20 17:06

    「VisualStudioからAzureのWebAppに発行する際、プロファイルを新規作成し、SQLデータベースを構築」

    もう一度同じ手順を踏むと今度は作成済みのSQLデータベースを選択でき、そこで接続テストのボタンがあると思います。

    キャンセル

  • 2017/06/20 17:53

    Visual Studio 2017を使用しております。公開するとまず発行画面が表示されます。
    プロファイルを新規作成すると「App Service の作成」が表示され、
    「サービス」→リソースの種類で「SQL DataBase」を追加。
    「SQL Database の構成」で作成済のSQL Server及びデータベース名を入力しますが、
    接続テストのボタンがありません。そのまま「OK」ボタンを押すと「App Service の作成」に戻り
    「作成」ボタンを押すとデプロイが実行されます。(作成ボタン左部にデプロイ中と出ます。)

    デプロイが終わると、元の発行画面にて新規作成したプロファイルが選択された状態となり
    発行ボタンを押すとAzureWebAppにデプロイされます。ブラウザが立ち上がり
    provider: SQL Network Interfaces, error: 52
    となります。

    キャンセル

  • 2017/06/20 18:01

    最近の発行ウィザードだと接続テストボタンが無いですね。失礼しました

    キャンセル

0

AzureDBの接続文字列は

Server=tcp:[server].database.windows.net,1433;Database=[Database];User ID=[user]@[server];Password=[Password];Trusted_Connection=False;Encrypt=True;


みたいな感じだったかと

あと

web.configのentityFrameworkの記述はコメントアウト済

の意図がよくわかりませんが、EntityFramework CodeFirstを使っているならコメントアウトしてはいけないと思いますよ
接続先を切り替えても同じように動くのが大きなメリットなのに、「試したこと」のような作業がもし必要だとしたら良さがスポイルしていますよね

 回答を追記(17/06/21)

数年前に習作で書いてた、開発時LocalDB、リリース時AzureDBのEntityFrameworkのCodeFirstのWeb.configを見つけたので、今回の話題に絡みそうなところだけ貼っておきます
その当時はこれで動作しました

<configSections>
  <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
  <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
</configSections>

<entityFramework>
  <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
    <parameters>
      <parameter value="mssqllocaldb" />
    </parameters>
  </defaultConnectionFactory>
  <providers>
    <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
  </providers>
</entityFramework>

 Web.Debug.configに書いたLocalDBの設定

<connectionStrings>
  <add name="DatabaseContext" connectionString="Data Source=(localdb)\v11.0;Integrated Security=True;AttachDbFileName=C:\UserDocument\App\Book.mdf;" providerName="System.Data.SqlClient" />
</connectionStrings>

 Web.Release.configに書いたAzureDBの設定

<connectionStrings>
  <add name="DatabaseContext" connectionString="Data Source=tcp:whm****gqh.database.windows.net,1433;Initial Catalog=SQLDB;User ID=user@whm****gqh;Password=Password" providerName="System.Data.SqlClient" />
</connectionStrings>

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/06/19 09:59

    webconfigに下記の記述が残っているとローカルDBを作成しようとすると思いコメントアウトしました。
    ```
    <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
    <parameters>
    <parameter value="mssqllocaldb" />
    </parameters>
    </defaultConnectionFactory>
    <providers>
    <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
    </entityFramework>
    ```

    こちらを元に戻し、接続文字列をご指摘の通りに変更したところ、
    メッセージが変わりましたがDB接続には失敗してしまいます。
    ```
    [SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 52 - Unable to locate a Local Database Runtime installation. Verify that SQL Server Express is properly installed and that the Local Database Runtime feature is enabled.)]
    ```

    キャンセル

  • 2017/06/19 11:51

    接続文字列のセクションを全て晒してみては
    もちろん認証情報は置き換えて
    なんか接続文字列にCodeFirstで使われる`add name="Context名" `を書いていなくて、defaultConnectionFactoryのmssqllocaldbでLocalDBを使うようになっている感じじゃないかなと思ったり

    キャンセル

  • 2017/06/20 11:16

    接続文字列のセクションはこちらになります。
    <connectionStrings>
    <add name="DefaultConnection"
    connectionString="Server==tcp:[Server].database.windows.net,1433;Database=[Database];User Id=[User]@[Server];Password=[PW];Trusted_Connection=False;Encrypt=True;"
    providerName="System.Data.SqlClient" />
    </connectionStrings>

    誤りや不足がありましたらご指摘ください。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.83%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る