質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.55%

Windows8.1とUbuntu14.04のデュアルブートに失敗します。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 5,928

tonkatu05

score 26

Windows8.1が入っているPCにUbuntuを入れることでデュアルブート環境にするつもりでした。

大体この記事の通りに作業を進めました。
http://satomablog.blog.fc2.com/blog-entry-6.html

CDからUbuntuを起動させてインストールに伴う設定によってWindowsのCドライブのパーティションを60GBほど縮小してそこにUbuntuを入れました。

そして次の設定がおそらくまずかったと思うのですが、
「ブートローダをインストールするデバイス」という項目を「/dev/sda」としました。


その結果Ubuntuの起動は行うことができるのですが、
Windowsが起動することができなくなりました。

PCを起動後GNU GRUB version 2.0〜beta2-9
が起動するのですが、Ubuntuしか起動できません。

Boot-Repair
https://help.ubuntu.com/community/Boot-Repair
を試してみたのですがGRUB起動後の選択肢が増えて
・Ubuntu
・Advanced options for Ubuntu
・Windows UEFI bootmgfw.efi
・Windows Boot UEFI loader
・EFI/ubuntu/MokManager.efi
・Windows Boot UEFI recovery bkpbootx64.efi
・Windows Boot Manager (on /dev/sda3)
・System setup
の項目が現れるのですが、Windowsと書かれたどの選択肢を選んでも、下記のようなエラーになります。

/EndEntire
file path: /ACPI(a034id0,0)/PCI(2,1f)Sata(0,0,0)/HD(3,300800,82000,ba4eb6d8f746df47,2,2)/File(\EFI\Microsoft\Boot)File(bootmgfw.efi)/EndEntire
エラー: cannot load image


Ubuntuの「デバイス」の項目から、WindowsのCドライブであろう項目は確認できるので、ファイルへアクセスすることは出来ています。

どうすればWindowsを起動できるでしょうか。

よろしくお願いします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

0

ブートメニューのセキュアブートを無効にすれば上手くいくかも??

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/03/30 13:02

    セキュアブートを無効にしたらgrubからも起動できるようになりました!
    ありがとうございます。お手数おかけしてすいません。

    (セキュアブートを無効に設定するためには管理者パスワードを設定しなければならず、それに気付くのに時間かかっていました、、、。)

    キャンセル

  • 2015/10/20 01:36

    私も同じサイトを見て同じ状況に陥っています。。。
    見る限りセキュアboot無効にしたらいいのですね。
    したいです。やった工程教えてください><

    キャンセル

  • 2015/10/20 16:50

    PC(BIOS)によって設定画面がガラッと変わるためちゃんとした手順は書けないのですが、
    とりあえずBIOSのメニュー開いて「secure boot」とかそれっぽいこと書いてあったらおもむろにdisableとかにしてみましょう。
    もし間違っても設定した場所覚えておいて元に戻せばおかしな事にはならないと思います。

    責任は取れませんが

    キャンセル

0

ちょっと今手元にubuntu入れたマシンがないのですが、GrubのGUIツールからbootメニューに出す・出さないを選択できるはずなので、まずそこに出てくるかどうか確認されてはいかがでしょうか。
なければインストール時に誤って消してしまったとか、、、

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/03/26 23:56

    出てこないですね、、、。消えてしまったのかもしれません。。。

    キャンセル

0

手元に環境がありませんが、下記の手順ではいかがでしょうか。
1.ubuntuで起動
2.Terminal起動
3.sudo update-grub
4.再起動

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/03/26 23:57

    試してみましたが変化ありませんでした、、、。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.55%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる