質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.63%

centos6にatomエディタはインストールできるでしょうか

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,992

ruuusaamarki

score 452

前提・実現したいこと

centos6にコマンドラインからatomエディタを
インストールしたいのですが可能でしょうか。

http://elearning.wsldp.com/pcmagazine/install-atom-centos7/

上記のページを参考にインストールを試みましたが
以下のようなエラーがでて対応策があるのか調査しておりますが
なかなか解決せず皆様のお力をお借りしようとまいりました。

発生している問題・エラーメッセージ

sudo yum install atom.x86_64.rpm
読み込んだプラグイン:fastestmirror
インストール処理の設定をしています
Determining fastest mirrors
epel/metalink                                                                                                                   | 7.0 kB     00:00
 * base: ftp.jaist.ac.jp
 * epel: ftp.jaist.ac.jp
 * extras: ftp.jaist.ac.jp
 * remi-safe: mirrors.thzhost.com
 * updates: ftp.jaist.ac.jp
base                                                                                                                            | 3.7 kB     00:00
base/primary_db                                                                                                                 | 4.7 MB     00:04
epel                                                                                                                            | 4.3 kB     00:00
epel/primary_db                                                                                                                 | 5.9 MB     00:05
extras                                                                                                                          | 3.4 kB     00:00
extras/primary_db                                                                                                               |  29 kB     00:00
mongodb-org-3.2                                                                                                                 | 2.5 kB     00:00
mongodb-org-3.2/primary_db                                                                                                      |  60 kB     00:00
mongodb-org-3.4                                                                                                                 | 2.5 kB     00:00
mongodb-org-3.4/primary_db                                                                                                      |  26 kB     00:00
nodesource                                                                                                                      | 2.5 kB     00:00
nodesource/primary_db                                                                                                           |  44 kB     00:00
remi-safe                                                                                                                       | 2.9 kB     00:00
remi-safe/primary_db                                                                                                            | 725 kB     00:02
updates                                                                                                                         | 3.4 kB     00:00
updates/primary_db                                                                                                              | 830 kB     00:00
パッケージ atom.x86_64.rpm は利用できません。
エラー: 何もしません

確認したこと

yumでのインストールやrpmでのインストールはできる環境だということは確認しました。

yum list
rpm -qa

検索をかけるとcentosでのインストールは難しい(パッケージの関係で)
atom本家のサイトには公式にファイルがないなどの情報がありましたが
某書籍と上記サイトにてyumでのインストール方法が載っていたので試した次第です。

当方のPCメモリの関連でcentos7でのテストができておらず恐縮ですが
centos7だったらいけるということもあるのでしょうか。

補足情報(言語/FW/ツール等のバージョンなど)

vagrant+virtualbox内に構築しているcentos6の環境です。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

glibcの段階でバージョン不足になっているようで、無理やり手動コンパイルさせても動かない、とのことでした(Qiita)。

Electronすら、、CentOS 6で動かそうとすれば専用のglibcの用意から必要になってしまう、とのことです(Qiita)。

「どうしてもCentOS 6で動かしたい」というのでなければ、素直にCentOS 7に入れることをおすすめします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/25 14:43

    コメントありがとうございます!

    そういうことだったのですね。

    一つ目のページは読んでいたのですが
    当方の知識不足で内容を理解することが難しかった状況でした。

    PCハードのアップデートとcentos7環境の構築の方向で進めたいと思います!
    現時点での判断ができ大変助かりました。ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.63%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る