質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • Ruby on Rails

    7495questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

rails コンソールで文字化け

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 3,099

mmm

score 21

railsでコンソールを立ち上げると
エンコードでエラーが出てしまうようになってしましました。

rubyとrailsのアンインストールは実行したのですが、特に治りませんでした。

こちらどのような対処をしたらよいでしょうか。

アドバイスいただけますと幸いです。

よろしくお願いします。

$ rails c
Loading development environment (Rails 4.1.6)
[1] pry(main)> puts "���������"
/Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/history.rb:106:in `write': "\xE3" from ASCII-8BIT to UTF-8 (Encoding::UndefinedConversionError)
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/history.rb:106:in `puts'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/history.rb:106:in `save_to_file'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/history.rb:50:in `call'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/history.rb:50:in `push'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_instance.rb:267:in `handle_line'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_instance.rb:243:in `block (2 levels) in eval'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_instance.rb:242:in `catch'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_instance.rb:242:in `block in eval'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_instance.rb:241:in `catch'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_instance.rb:241:in `eval'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/repl.rb:77:in `block in repl'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/repl.rb:67:in `loop'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/repl.rb:67:in `repl'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/repl.rb:38:in `block in start'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/input_lock.rb:61:in `call'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/input_lock.rb:61:in `__with_ownership'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/input_lock.rb:79:in `with_ownership'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/repl.rb:38:in `start'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/repl.rb:15:in `start'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/pry-0.10.1/lib/pry/pry_class.rb:169:in `start'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/console.rb:90:in `start'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/console.rb:9:in `start'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/commands_tasks.rb:69:in `console'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/commands_tasks.rb:40:in `run_command!'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands.rb:17:in `<top (required)>'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `block in require'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in `require'
    from /Users/masah/cospic/bin/rails:8:in `<top (required)>'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:241:in `load'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:241:in `block in load'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in `load_dependency'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:241:in `load'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /Users/masah/.rbenv/versions/2.1.4/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from -e:1:in `<main>'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

0

ここは参考になりませんか?(今、Macを使えないので未確認ですが)

http://qiita.com/irohiroki/items/c82657b5cb4bdb2aaac4

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/03/18 01:04

    こちらと下記記事を参考にインストールし直したところ
    解決しました!
    http://qiita.com/Tamadon/items/347baf2ba89ccde89624
    ありがとうございます!

    キャンセル

0

まず、こういう質問を投げるときは、自分の使っている環境を詳しく書きましょう。
それと、同じ現象を起こすための最小限のコードを書いて、そのコードを開示して質問すると良いです。
(もっとも、そこまですると、原因がわかってしまうことが多いですけどね。)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/03/17 08:10

    環境=OS、Rubyのバージョンなど。

    キャンセル

  • 2015/03/17 08:49

    すみません。
    OS -mac10.10.2
    Ruby2.1.4
    Rails-4.1.6

    です。

    コードとしては
    ```lang-<ここに言語を入力>
    rails c
    p "S"
    →"S"
    p "あ"
    →エラー
    ```

    という具合です。

    失礼いたしました。

    キャンセル

0

rails cでエラーが出るとのことですが、pryコマンドで起動した場合も同様のエラーが発生しますか?
だとすると .pryrcファイル内で良くないことをしている可能性ががあります。
(あるいは.pryrcファイルの文字コードがUTF-8でないなど)


すいません、そもそも起動時にエラーが出ると思って読んだのですが、

pry(main)> puts "���������"

このコードは手で入力しているのですか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/03/17 10:36

    アドバイスありがとうございます!

    はい。
    手入力で日本語を入力した際にエラーが起き、コンソールが閉じてしまいます。

    英数字は問題ないのですが、

    キャンセル

関連した質問

  • 解決済

    http://localhost:3000/ が開けません。

    前提・実現したいこと Ruby on rails を用いて新しくアプリを作成するため、 「http://localhost:3000/」 を開こうとしたところ、 下記のエラー

  • 解決済

    railsのgemで導入したJQueryプラグインファイルについて

    いつも皆さんにはお世話になっています。 この度、gemでFullcalendarというJQueryで作成しているカレンダーを導入したのですが、少しカスタマイズを加えたいと思い

  • 解決済

    $bundle install ができない

    $bundle install をするとこのようなエラーが出ます。 Errno::EACCES: Permission denied @ rb_sysopen - /Users

  • 解決済

    rubyのsplit関数のソースについて

    おはようございます rubyのsplitやchomp関数のソースがみたくて、rubyのgitをcloneしたのですが、それらしい部分がどこにもありませんでした。 かかれ

  • 解決済

    Railsのコントローラーのテストでのエラー

    Railsアプリケーションプログラミングを学習しながら作っていますが、コントローラーのテストを実行使用としたらエラーが出て解決出来ずに困っております。実行したコードは下記になります

  • 受付中

    rails appのbundleがインストールできない

    bundle install Fetching gem metadata from https://rubygems.org/......... Fetching version

  • 解決済

    楽しいRuby 第5版

    楽しいRuby 第5版 8.7.2 名前空間のテスト方法(背景ピンク色の部分)のテストは、Rubyコンソールのirbを使用 してテストするのが適当でしょうか? また、その場

  • 解決済

    Rails s エラーが出て困っています。

     前提・実現したいこと railsの動作確認を行おうとしています。 $rails s を実行しようとすると下記の様に表示されて困っています。 どなたか教えて頂けませんでしょうか

同じタグがついた質問を見る

  • Ruby on Rails

    7495questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。