質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.78%

SoapClient、DOMDocumentの有効ってどうすればいいのでしょうか。

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,670

score 79

掲題の件ですが、有益な情報が見つからず解決できておりません。

現在プラグインにwoocommerceをインストールし、ショッピングサイトを構築しているのですが、
システム状態をみると以下の文言が表示されており、改善する必要がありそうです。

具体的にどのようにすれば改善できるのでしょうか。

■ご利用中のサーバーでは SoapClient クラスが有効化されていません。SOAP を使用している一部の決済プラグインが予期しない動作をするかもしれません。

■お使いのサーバーでは DOMDocument クラスが有効化されていません。HTML / マルチパートメールと一部の拡張機能は DOMDocument なしでは動作しません。

サーバは、
サーバー:さくらVPS
OS:centOS7
です。

もし詳しい方がいらっしゃればご教示いただけますと、ありがたいです。

【追記:SoapClient クラスに関して】

下記のようにコマンドを打った結果、
うまくインストールできなかったようです。何が問題なのでしょう。

打ったコマンド:

yum install php-soap


表示された結果:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: www.ftp.ne.jp
* epel: ftp.riken.jp
* extras: www.ftp.ne.jp
* remi-safe: mirror.bebout.net
* updates: www.ftp.ne.jp
Resolving Dependencies
--> Running transaction check
---> Package php-soap.x86_64 0:5.4.16-42.el7 will be installed
--> Processing Dependency: php-common(x86-64) = 5.4.16-42.el7 for package: php-soap-5.4.16-42.el7.x86_64
--> Finished Dependency Resolution
Error: Package: php-soap-5.4.16-42.el7.x86_64 (base)
Requires: php-common(x86-64) = 5.4.16-42.el7
Installed: php-common-7.0.14-1.el7.remi.x86_64 (@remi-php70)
php-common(x86-64) = 7.0.14-1.el7.remi
Available: php-common-5.4.16-42.el7.x86_64 (base)
php-common(x86-64) = 5.4.16-42.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

7は使用してないので細かい所が違うかもしれませんが、yum search php-xml とか yum search php-soapで検索して適切なものをinstallするといいかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/11 11:46

    コメントありがとうございます。下記のようにコマンドを打った結果、
    うまくインストールできなかったようです。何が問題なのでしょう。

    打ったコマンド:
    yum install php-soap

    表示された結果:
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: www.ftp.ne.jp
    * epel: ftp.riken.jp
    * extras: www.ftp.ne.jp
    * remi-safe: mirror.bebout.net
    * updates: www.ftp.ne.jp
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-soap.x86_64 0:5.4.16-42.el7 will be installed
    --> Processing Dependency: php-common(x86-64) = 5.4.16-42.el7 for package: php-soap-5.4.16-42.el7.x86_64
    --> Finished Dependency Resolution
    Error: Package: php-soap-5.4.16-42.el7.x86_64 (base)
    Requires: php-common(x86-64) = 5.4.16-42.el7
    Installed: php-common-7.0.14-1.el7.remi.x86_64 (@remi-php70)
    php-common(x86-64) = 7.0.14-1.el7.remi
    Available: php-common-5.4.16-42.el7.x86_64 (base)
    php-common(x86-64) = 5.4.16-42.el7
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    キャンセル

0

バージョン 5.4.16-42.el7 のPHP-Soapをインストールしようとしているが、システムにインストールされているPHPのバージョンは7.0.14.el7なのでインストールできないという状況です。

エラーメッセージに
Requires: php-common(x86-64) = 5.4.16-42.el7
とあります。
5.4.16-42.el7 のPHP-Soapは、5.4.16-42.el7のPHPにしかインストールできないのです。

バージョン7.0.14.el7のPHP-Soapをインストールするか、PHPをバージョン 5.4.16-42.el7に戻して、5.4.16-42.el7 のPHP-Soapをインストールのが解決方法かと思います。

php-soapの最新バージョンは7.0.19になっているようですから、この際7.0.19で揃えてはいかがでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/25 13:08

    >7は使用してないので細かい所が違うかもしれませんが、yum search php-xml とか yum search php-soapで検索して適切なものをinstall

    $ yum install php-soap
    と打ったのですが、
    Loaded plugins: fastestmirror
    Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
    You need to be root to perform this command.
    と返ってきました。

    コマンドが間違っているのでしょうか。

    キャンセル

  • 2017/05/25 13:35

    >yum search php-xml とか yum search php-soapで検索して適切なものをinstallする
    どのコマンドをたたけばいいのか、検索しても有益な情報が見つからなくて・・・
    具体的にどのコマンドをたたけばよいかご存知でしたらご教示いただけますとありがたいです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る