質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.45%

  • Ruby on Rails

    9091questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

solidusをインストール直後からrailsコマンドが使えなくなる件について

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,123

dialbird

score 329

ECサイトテンプレートのSolidusを使ってみようと、以下のようなGemfilebundleしたら、エラーになりました。

source 'https://rubygems.org'

git_source(:github) do |repo_name|
  repo_name = "#{repo_name}/#{repo_name}" unless repo_name.include?("/")
  "https://github.com/#{repo_name}.git"
end

gem 'rails', '~> 5.1.0'
gem 'pg', '~> 0.18'
gem 'puma', '~> 3.7'
gem 'sass-rails', '~> 5.0'
gem 'uglifier', '>= 1.3.0'
gem 'therubyracer', platforms: :ruby
gem 'coffee-rails', '~> 4.2'
gem 'jbuilder', '~> 2.5'

gem 'solidus'
gem 'solidus_auth_devise'
# 以下略

エラー文

Bundler could not find compatible versions for gem "rails":
  In snapshot (Gemfile.lock):
    rails (= 5.1.0)

  In Gemfile:
    rails

    solidus was resolved to 1.0.0, which depends on
      solidus_frontend (= 1.0.0) was resolved to 1.0.0, which depends on
        canonical-rails (~> 0.0.4) was resolved to 0.0.11, which depends on
          rails (< 5.0, >= 3.1)

    solidus was resolved to 1.0.0, which depends on
      solidus_core (= 1.0.0) was resolved to 1.0.0, which depends on
        deface (~> 1.0.0) was resolved to 1.0.2, which depends on
          rails (>= 3.1)

    solidus was resolved to 1.0.0, which depends on
      solidus_core (= 1.0.0) was resolved to 1.0.0, which depends on
        rails (~> 4.2.0)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

どうやらrailsのバージョンと噛み合わないようなので、以下のようにrailsのバージョンを指定しないようにしてから、bundle updateしたところ、とりあえずbundleは通りました。

# ここを
gem 'rails', '~> 5.1.0'

# こうしただけ
gem 'rails'

しかし、今度はSolidusをインストールするためのコマンド
bundle exec rails g spree:install
を実行するとエラーが出るようになってしまいました。(プロジェクト名はShopShop)

/home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/railtie/configuration.rb:95:in `method_missing': undefined method `load_defaults' for #<Rails::Application::Configuration:0x007f9f135c9388> (NoMethodError)
    from /home/vagrant/shopshop/config/application.rb:12:in `<class:Application>'
    from /home/vagrant/shopshop/config/application.rb:10:in `<module:Shopshop>'
    from /home/vagrant/shopshop/config/application.rb:9:in `<top (required)>'
    from /home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/commands/commands_tasks.rb:156:in `require'
    from /home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/commands/commands_tasks.rb:156:in `require_application_and_environment!'
    from /home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/commands/commands_tasks.rb:143:in `generate_or_destroy'
    from /home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/commands/commands_tasks.rb:60:in `generate'
    from /home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/commands/commands_tasks.rb:49:in `run_command!'
    from /home/vagrant/.rbenv/versions/2.4.0/lib/ruby/gems/2.4.0/gems/railties-5.0.2/lib/rails/commands.rb:18:in `<top (required)>'
    from bin/rails:4:in `require'
    from bin/rails:4:in `<main>'

ちなみにこのエラーはこのコマンドに限らず、railsコマンド全般で出ます。

どなたかわかる方、何が問題かのご指摘をお願いいたします。
rails -vでは5.0.2と出ました)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

僕も同じところで躓きました。
まだ完壁に解決できたわけじゃないけれど、そこから進展があったので回答します。

gem install rails --version="3.2.17" #指定バージョンをインストール
これで、bundleに設定したバージョンのrailsをインストールします。
bundle install でrails (~> 4.2.0)というエラー文が出てるので、railsは4.2.0以下じゃないとだめですよってことなのだと思います。
なのでgemfileのrailsを4.2.0にして、gem install rails --version="4.2.0"にすればよいと思いますよ。

追記: rails 4.2.0をinstallしてみましたがrailsコマンドが使えませんでした。また進展がありましたら、ご報告します。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/05/16 21:09

    AkiPonN1さん
    ご返答ありがとうございます

    ちょうど先ほど解決いたしました!
    まさにおっしゃる通りバージョンの問題で、Gemfileで4.2系のRailsをインストールした後、そのディレクトリでbundle exec rails newしてあげたところ、Rails4.2系統のappができて、そこから先は思った通りの挙動となりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.45%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby on Rails

    9091questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。