質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.77%

iOSアプリ開発出来るバージョンのxCodeがインストールできるMac book air 年

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 3,470

learning_ci

score 22

こんにちは。Mac book airの購入を考えています。
下記の記事と似た質問なのですが、2017年現在の状況を知っている方に教えていただきたいです。

https://teratail.com/questions/49322

リンク先を読むと、「iOSアプリをリリース出来るバージョンのxCodeがインストールできるMac book air」は、2017年4月現在だとLate 2010以降ということになると思います。

しかしリンク先によると、来年には使えなくなるということですよね。

すると単純な足し算で、
「2年くらいはアプリ開発してリリースしたいから、Late 2012以降」
のような計算でいいのでしょうか?

もしくは、Mac book air自体の発売中止など、単純計算ではいかない販売状況の変化などはあるのでしょうか?

乱文失礼いたしました。どうぞよろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+4

以前に参照先の質問の回答をしたものです。

リンク先を読むと、「iOSアプリをリリース出来るバージョンのxCodeがインストールできるMac book air」は、2017年4月現在だとLate 2010以降ということになると思います。

正確には違います。
正確には「最新のiOS10.3をテスト機として使用できるXcode8.3(対応MacOS:Sierra以上)がインストールできるMac book airは、2017年4月現在だとLate 2010以降」です。

誤解を解きたいのは、最新のXcodeでないとアプリをリリースできないのではなくて、ちょっと古いXcodeを使ってアプリを作っても、Appleへの審査依頼とリリースは可能だと言うことです。自分が今使っているiPhoneのOSがiOS10.3だったらその自分の実機を古いXcodeのテスト機として使えないと言うだけです(これも正確に言うと裏技があるのですが動作保証はされてないので「古いXcodeでは動作させることができない」としておきます)。

最新のXcodeを使ってアプリを開発しないと最新のiOS10で動作するアプリが作れないと言うわけでもありません。古いiOSの機能しか使わないのだったら、古いXcodeで開発したアプリでも最新のiOS10で動作できる可能性は高いです。iOSをバージョンアップしたからといって、今まで使っていたアプリが全然使えなくなるわけではないのと同じです。Appleは昔作った古いアプリを最新のiOSでもなるべく動作できるように設計しています(ただし、一部の機能の互換性がなくなって最新のOSで使えなくなるアプリも一部にはあります。そのため、「動作できる可能性は高い」としています。)

どれくらい古いXcodeでAppleの審査が通らなくなるかは、あまりはっきりした情報がなく、
http://stackoverflow.com/questions/35285502/minimum-xcode-version-to-upload-to-app-store-as-on-february-2016
にあるように、作ったアプリをArchiveのValidate機能で検査すればわかると言うことくらいしか見つけられませんでした。おそらくXcode7系は今でも大丈夫だと思います。Xcode6は微妙です。Xcode5は、64bit対応できないので既にNGであることが2014年頃にAppleから発表されています。
(参考)
http://cloud9blog.jp/podcast/349/

本題に戻りますが、

すると単純な足し算で、 
「2年くらいはアプリ開発してリリースしたいから、Late 2012以降」 
のような計算でいいのでしょうか?

もしくは、Mac book air自体の発売中止など、単純計算ではいかない販売状況の変化などはあるのでしょうか?

Appleは、そんなにきちんと定期的にリリースしたりしません。ここ数年の傾向では1年単位でメジャーバージョンアップされてますが、今後はどうなるかわかりません。楽観的見通しは立てない方が良いと言うことです。私が言えるのは、最新状況に対応するために、購入時点でできる限り最新のMacを購入するべきだと言うことだけです。

古いMacと古いXcodeで開発したのでいいのでしたら、それでも構いませんが、iOSは一度OSをバージョンアップすると古いバージョンに戻せませんので、間違って更新しないよう注意してください。
そして、最新のOSでテストをしないでAppleに審査依頼した時、それが最新OSで動作すればリリースできますが、最新OSで動作しなくてリジェクトされた場合は、原因を調べるのがおそらくかなり難しいと思います。
それと、Webサイトの情報は最新のXcodeに合わせた情報にどんどん更新されますので、古いXcodeにあった記事は少なくなり、この質問サイトでも古いXcodeに対する回答は得られにくくなります。
特にアプリ開発をこれから勉強すると言うことでしたら、そのあたりも考慮した方が良いと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/04/21 11:08

    現時点では、Xcode7は間違いなく大丈夫です。

    キャンセル

  • 2017/04/21 12:00

    大変丁寧なご回答ありがとうございます!とても助かりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る