質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Laravel 5

    1877questions

    Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

  • composer

    151questions

    Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Mac Laravel5.4 をアンインストールし、Laravel5.1 をインストールするには

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 957

qmomo

score 37

前提・実現したいこと

mac、composer 1.3.2 ,PHP 7.0.15を使用しています。 
Laravel5.4 をアンインストールし、Laravel5.1 をインストールするには
どうしたら良いでしょうか?

アプリケーションファルダに、Laravel5.3が存在していないのですが、
php artisan --versionでは、
Laravel Framework 5.4.15
と表示されています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

プロジェクト作成コマンドのお尻にバージョンをつけるとそのバージョンのLaravelのプロジェクトディレクトリが作成されます。

composer create-project laravel/laravel --prefer-dist プロジェクト名 5.1

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 受付中

    laravelのインストール

    公式HPで見たところLaravelを使用するにはHomesteadというのを利用するように推奨されていたので、その方法でインストールしようとしています。 しかしこの方法では初めに

  • 解決済

    ダウンロードボタンを押すとパス付きのZIPファイルをダウンロードしたい

    ダウンロードボタンを押すと パスワードがかかっているZIPファイルをダウンロードして 中にはTSVファイルがはいているようにしたいです。 tsvファイルにはDBからの情報を書きだし

  • 受付中

    laravelのlocalhost接続

    前提・実現したいこと laravelのプロジェクトを作成し、php artisan serveコマンドを実行後、localhost:8000にアクセスしてもデモページ?(白い背景に

  • 解決済

    nginx で php を動かしたい

    nginx 入門者です。 Laravel の勉強を始めていて、問題にぶつかったのでヘルプをお願いします。  症状 Laravel の publicディレクトリの中にある .ph

  • 解決済

    phpの5.6.4のバージョンが見つかりません。

    お世話になります。 laravelのバージョンを最新版にしようと思い、composer.jsonを変更するとphpのバージョンが5.6.4ではないという理由でエラーが出ます。 なの

  • 解決済

    Unknown: php_network_getaddresses: getaddrinfo fai...

    いろいろIPアドレスを変更して試してみたのですが、うまくいきませんでした。 よろしくお願いします。  前提・実現したいこと 【環境】 php-version:7.1.15 la

  • 解決済

    localhost:3000に接続できない(Laravel + Nuxt.js + Vagrant ...

     前提・実現したいこと VirtualBox + Vagrant + HomesteadでLaravel + Nuxt.jsの開発環境構築を行っています。 Laravel側では上手

  • 解決済

    laravel マイグレーション実行時のエラー

    マイグレーション実行時にこんなエラーが出ます。。。 Illuminate\Database\QueryException : SQLSTATE[HY000] [1045

同じタグがついた質問を見る

  • Laravel 5

    1877questions

    Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

  • composer

    151questions

    Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。