質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.03%

VMwareでつくったWindows10の仮想環境でインターネット接続ができない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 4,186

mx3

score 185

前提・実現したいこと

Windows7にWindows10の仮想環境をつくってMicrosoft Edgeを動かしたいです。

発生している問題・エラーメッセージ

Windows10とEdgeを起動するところまではいきましたが、Edge上に「You're not connected」と表示されています。
インターネット接続できていない状態です。

イメージ説明

試したこと

ホストOSはWindows7で有線LANでネットワーク接続されています。
自分で調べて、
・ブリッジ接続すれば良い
・ネットワーク接続のプロパティで「VMware Bridge Protocol」は1箇所しかチェックを入れてはいけない

というところまでは分かったため、そうしたのですが改善がありません。

イメージ説明

ネットワーク接続は上記のようなかたちで、
ローカルエリア接続以外は「VMware Bridge Protocol」にチェックを入れていません。

![イメージ説明説明](9f6fd4454fc90c2777f090b9c047b403.png)](2add2d47fd9ecf901f2de5e0458aa66f.png)

仮想マシン設定は下のようにしています。ウィンドウは『アダプタの設定』をクリックした時の表示です。

イメージ説明

補足

同じWMwareでWin8.1(IE11を使うため)の仮想マシンを設定していますが、こちらはブリッジ接続で問題なくインターネット接続できます。

どうやったら、Windows10の方でもインターネットに接続できるようになるでしょうか?
Web上の情報を探しながら3時間ほど試しましたが、初心者ということもありどうしても解決できません。。
お分かりになる方どうか教えてください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • mx3

    2017/03/21 16:56

    ゲストはどうやって確認したらいいか分からないのですが、IP設定はなにも触っていない状況です。

    キャンセル

  • over

    2017/03/21 17:08

    ホスト、およびゲストのコマンドプロンプトでipconfig コマンドを実行した結果はどうなるでしょう?

    キャンセル

  • mx3

    2017/03/21 17:19

    求められている値か分かりませんが... それぞれIPv4アドレスは次のようになっています。 ▼ホスト ローカルエリア接続 10.0.1.5 VirtualBox Host-Only Network 192.168.56.1 VirtualBox Host-Only Network 192.168.33.1 VMware Network Adapter VMnet1 192.168.232.1 VMware Network Adapter VMnet8 192.168.200.1 ▼ゲスト 「Windows IP Configuration」とだけ表示されます

    キャンセル

回答 1

checkベストアンサー

0

頂いたコメントより、ゲストOSはDHCPサーバからIPアドレスが取得できていないようです。

同じWMwareでWin8.1(IE11を使うため)の仮想マシンを設定していますが、こちらはブリッジ接続で問題なくインターネット接続できます。

上記は同一のホストで稼働するマシンでしょうか?
そうであればホストのFW、ウイルス対策ソフトが制限となっている可能性は少なそうです。

以下と表示されていることから、導入されているVMware ソフトウェアがWindows10に対応していないため、イーサネットドライバがOSにインストールされていないことが原因と考えています。

ゲスト 「Windows IP Configuration」とだけ表示されます

「アダプタ設定の変更」から、ネットワークアダプタが表示されているか確認してください。
表示されていなければ、VMware ソフトウェア側でWindows10に対応していない可能性大です。

少し調べてみました。
VMware Workstation 12 からWindows10対応しているようです。
以前はWorkStationは有償でしたが、無償になったようです。
Plyerからの上書きインストールができるようなので試してみては如何でしょうか?
ただし、旧環境に悪影響がでないとも限らないので自己責任でお願いします。

上記がマッチしない場合はDHCPリソースの枯渇が疑われます。
DHCPサーバのリリース範囲を確認してみては如何でしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/03/21 20:01

    回答ありがとうございます!

    >上記は同一のホストで稼働するマシンでしょうか?

    はいそうです。

    >「アダプタ設定の変更」から、ネットワークアダプタが表示されているか確認してください。

    「アダプターの設定の変更」を表示したキャプチャを質問のところに添付しているのですが、この中の、
    VMWare Network Adapter VMnet1
    VMWare Network Adapter VMnet8
    この2つはネットワークアダプタではないのでしょうか?

    >VMware Workstation 12 からWindows10対応しているようです。

    情報不足で申し訳ありません。いま使っているのは、VMware Workstation 12 です。本日インストールしたばかりなので、恐らく最新だと思います。

    となると、DHCPリソースの枯渇ということになりますでしょうか?
    こういう作業は今回ほぼはじめてで、しかも自宅なので、枯渇するほどは使っていない気がするのですが、調べてみようと思います!

    1点、補足情報ですが、今回MicrosoftのWebサイトから、仮想マシンイメージをダウンロードしました。
    https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/
    Win8.1も同じところからダウンロードしました。

    気になっているのが、Microsoft Edge on Win 10 Preview と VirtualBoxの組み合わせで、「MSEdge - Win10_preview.ova」というファイルをダウンロードしたのですが、VirtualBoxではOVFしかサポートしてないといってエラーが出て進めなかったので、「MSEdge - Win10_preview.ova」をダブルクリックしたところ、自動的にVMWareが立ち上がり、インポートすることができました。

    元々、VMWare用のイメージではないから、不具合が起きている可能性もあるのでしょうか?

    キャンセル

  • 2017/03/21 20:28

    インターネット接続できました!!!!!!

    >イーサネットドライバがOSにインストールされていないことが原因と考えています。

    この言葉をヒントに、ネットワークアダプターを再インストールする方法を探して解決しました!

    再インストールの方法は、下記のページを参考にしました。
    https://121ware.com/qasearch/1007/app/servlet/relatedqa?QID=018281

    仰るとおり、ネットワークアダプターがインストールされていない状態でしたので、「Update Driver」することで「Intel(R)PRO/1000 MT Network Connection」というネットワークアダプターがインストールされ、無事にインターネットにアクセスすることができるようになりました!!

    すごく嬉しいです!何度もご対応いただき、本当にありがとうございました!!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる