Error: Could not find gradle wrapper within Android SDK.

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 3,382

ksyunnnn

score 59

前提・実現したいこと

CordovaでiOS/Androidのハイブリッドアプリを作成しています。
cordova platform add androidまではうまく行くのですが、
cordova emulate androidcordova build androidを行うとエラーが発生します。

エラーをどのようにすれば回避できるのか知りたいです。よろしくお願いします。

※iOSプラットフォームでのコマンド実行は問題なくできました。

発生している問題・エラーメッセージ

cordova emulate android/cordova build android実効後

ANDROID_HOME=/Users/kobashi/Library/Android/sdk
JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_121.jdk/Contents/Home
Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
Looked here: /Users/kobashi/Library/Android/sdk/tools/templates/gradle/wrapper

試したこと

以下を確認

  • Android SDKがアップデートされていること
  • Android Studio/cordovaを使用しているコンソールの再起動

お手数ですが、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+3

Android SDKをアップデートしたということですが、SDK Toolsがr25.3.1になっているのではないでしょうか。このリビジョンでtools/templatesは削除されてしまいました。その影響でしょう。
http://tools.android.com/recent/androidsdktoolsrevision2530feb2017

ダウンロードページ(https://developer.android.com/studio/index.html)の一番下にある「コマンドライン ツールのみ入手する」では、今日現在はまだr25.2.3が配布されているので、これをダウンロード・展開して、作られたtoolsフォルダーを差し替えれば良いでしょう。

SDK Tools r25.3では、他にもStandaloneのSDK ManagerやAVD Managerが廃止されたりするなど、かなり大きな変更となっているので、それらの影響を受けるようならば、SDK Toolsは当面r25.2.3のままアップデートを控えるしかないのではないかと思います。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/03/10 11:24

    ご指摘の通りの原因だったようです。
    確認したところ、SDK Toolsがr25.3.1になっており、tools/templatesは存在しておりませんでした。

    ご提案の通り、古いバージョンのものをDLしフォルダを差し替えたところ、無事ビルドが完了しました。

    本当に助かりました。ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る