質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.42%

  • WordPress

    7879questions

    WordPressは、PHPで開発されているオープンソースのブログソフトウェアです。データベース管理システムにはMySQLを用いています。フリーのブログソフトウェアの中では最も人気が高く、PHPとHTMLを使って簡単にテンプレートをカスタマイズすることができます。

ローカルでWordPressの更新ができなくなった(Yosemiteにアップデート直後)

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,844

iniesta

score 29

先ほどMacのOSをYosemiteにアップデートしたのですが、それからローカルで開発中のWordPressサイトを触ってみたところ、更新(翻訳の更新)ができなくなっていました。

エラーメッセージは以下の通りです。

「Warning: copy(/Library/WebServer/Documents/プロジェクト名/wp-content/languages/themes/twentyfifteen-ja.po): failed to open stream: Permission denied in /Library/WebServer/Documents/プロジェクト名/wp-admin/includes/class-wp-filesystem-direct.php on line 231

ファイルをコピーできませんでした。 /Library/WebServer/Documents/co-media/wp-content/languages/themes/twentyfifteen-ja.po

翻訳の更新に失敗しました。」

「wp-content/languages/themes/twentyfifteen-ja.po」を全て777にしてみましたがダメでした...。
おそらくOSのアップデートで何かの設定が変わってしまったのだと思うのですが、どこのパーミッションを直したらよいのでしょうか?
ちなみに、「/Library/WebServer/Documents/プロジェクト名」までは全て755になっています。

どなたかアドバイスお願いします!
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

こんにちは。

原因は、OSを Yosemiteにアップデートしたことで、標準ではいっている Apacheや PHPが再インストールされたことによるものと思われます。

ちなみに、Apacheは(2.2系から)2.4系になっているはずです。
ためしに、ターミナルで「httpd -v」か「apachectl -v」を打ち込んでバージョンを確認してみてください。

対処方法は、こちら(リンク)のページを参考になさってください。

なお、不明な点があるようでしたら、「Yosemite アップデート後 ローカル環境 WordPress」のクエリで検索していただければ、そのほかにもご参考いただけるページがヒットするはずです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/02/17 18:52

    いつもご丁寧に回答していただき、本当に助かります!

    リンク先に書いてあった通りにPHP、Apache、MySQLを設定等をし直したのですが、相変わらず同じエラーが出て翻訳を更新できません・・・。

    どうしてでしょうか?

    キャンセル

  • 2015/02/18 10:02

    そうでしたか……

    あとは、Apacheの設定ファイル(httpd.conf)が書き換えられているかもしれないことくらいかも、と思って検索したところ下記のようなブログがありました。
    http://slackhack.net/1145.html
    この再設定は、ダメ元でやってみてもいいかもしれません。

    それから、WordPressのアップデート関連のファイルはたしか wp-adminと wp-includeにはいっていたはずのですので、こちらのパーミッションを 755にしてみる、さもなければ 777にして更新し、作業終了後に 755にしておくといったこともためしてみる必要があるのではないかと思います。

    あいまいなままですが、現状で考えられるのはこのくらいです。

    キャンセル

  • 2015/02/18 10:12

    ひとつ確認させてください。

    WrodPressそのものは(新規投稿などの機能)使えるのでしょうか。
    僕の場合、これは本番環境でのことですが、プラグインなどの更新があった際に、ときとして「翻訳が更新できませんでした。」とメッセージがでることがあります。
    ただ、これは経験的に問題は起こらない(ことが多い)ので無視してしまいます。というのは、つぎの更新の際には正常にアップデートが行われるからです。原因は特定していませんが、サーバーの状態によるのかもしれません。

    キャンセル

  • 2015/02/18 22:24

    Apacheの再設定、パーミッションを777にしてもダメでした・・・。

    新規投稿等は問題なくできています。

    とりあえず無視しておこうと思います。
    回答ありがとうございました!

    キャンセル

  • 2015/02/19 10:43

    そうでしたか。
    気がかりではありますが、当面は、無視しておくしかないのかもしれませんね。

    キャンセル

  • 2015/02/19 11:52

    たった今、無事直りました!

    WordPressのインストールフォルダ以下の所有者をApacheの実行ユーザーに変更したところ、問題が解消されました。
    http://www.nekotricolor.com/entry/2012/11/13/612/

    ありがとうございました!

    キャンセル

  • 2015/02/19 12:38

    ypponさん、解決できてなによりでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.42%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • WordPress

    7879questions

    WordPressは、PHPで開発されているオープンソースのブログソフトウェアです。データベース管理システムにはMySQLを用いています。フリーのブログソフトウェアの中では最も人気が高く、PHPとHTMLを使って簡単にテンプレートをカスタマイズすることができます。