質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

Ruby railsチュートリアルでのrails testコマンド

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 716

MASA22

score 13

前提・実現したいこと

rails チュートリアル四版で rails test を入力したら発生しました。

MacOS Sierra  rails 5.0.0.1です。

発生している問題・エラーメッセージ

Warning: Running `gem pristine --all` to regenerate your installed gemspecs (and deleting then reinstalling your bundle if you use bundle --path) will improve the startup performance of Spring.
Running via Spring preloader in process 20383
/Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/sqlite3_adapter.rb:27: [BUG] Segmentation fault at 0x00000000000110
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-darwin16]

-- Crash Report log information --------------------------------------------
   See Crash Report log file under the one of following:
     * ~/Library/Logs/CrashReporter
     * /Library/Logs/CrashReporter
     * ~/Library/Logs/DiagnosticReports
     * /Library/Logs/DiagnosticReports
   for more details.

-- Control frame information -----------------------------------------------
c:0072 p:---- s:0284 e:000283 CFUNC  :initialize
c:0071 p:---- s:0282 e:000281 CFUNC  :new
c:0070 p:0167 s:0277 e:000276 METHOD /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapter
c:0069 p:0023 s:0270 e:000269 METHOD /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapter
c:0068 p:0025 s:0267 e:000266 METHOD /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapter
c:0067 p:0022 s:0264 e:000263 METHOD 



長すぎて省略します


 1684 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/minitest-5.10.1/lib/minitest/pride_plugin.rb
 1685 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/railties-5.0.0.1/lib/rails/test_unit/minitest_plugin.rb
 1686 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/activesupport-5.0.0.1/lib/active_support/testing/stream.rb
 1687 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/railties-5.0.0.1/lib/rails/generators/testing/behaviour.rb
 1688 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/railties-5.0.0.1/lib/rails/generators/testing/setup_and_teardown.rb
 1689 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/railties-5.0.0.1/lib/rails/generators/testing/assertions.rb
 1690 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/thor-0.19.4/lib/thor/shell/basic.rb
 1691 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/railties-5.0.0.1/lib/rails/generators/test_case.rb
 1692 /Users/masashihiraishi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/activesupport-5.0.0.1/lib/active_support/testing/autorun.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
Don't forget to include the above Crash Report log file.
For details: http://www.ruby-lang.org/bugreport.html

環境でミスっているのかもわかりませんが、自分ではよくわかりません。
お力を貸していただければ幸いです。

>自己解決しました。 
http://scior.hatenablog.com/entry/2017/01/31/034750

>こちらに乗っている通りにsqlite3を1.3.12に設定すると正常に動作しました。 
>やり方は上記を参照してください!

><追記> 
>この後、何回かできていたのですがまたほぼ同じエラーが出て来ました。sqlite3を1.3.13にあげれば治りました。

<追記1>
再発しました。
治っていません、ruby2.2.2との相性がsqlite3が悪いという記事を見たためruby2.3.3にバージョンアップすると一瞬治りましたが、再び再発しました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

自己解決しました。
http://scior.hatenablog.com/entry/2017/01/31/034750

こちらに乗っている通りにsqlite3を1.3.12に設定すると正常に動作しました。
やり方は上記を参照してください!

<追記>
この後、何回かできていたのですがまたほぼ同じエラーが出て来ました。sqlite3を1.3.13にあげれば治りました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る