質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Ruby

    7653questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7260questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • MacOS(OSX)

    1902questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

Macにrailsをインストールしようとしたが、エラーが出てしまった。

受付中

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 363

8y1oCu

score 2

前提・実現したいこと

macにrailsをインストール際にエラーメッセージが出ました。

発生している問題・エラーメッセージ

miyagucuyanoAir:~ miyaguchikazuya$ gem install rails
Fetching: activesupport-5.0.1.gem (100%)
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory.
miyagucuyanoAir:~ miyaguchikazuya$ sudo gem install rails
Password:
ERROR:  Error installing rails:
    activesupport requires Ruby version >= 2.2.2.
miyagucuyanoAir:~ miyaguchikazuya$ 

試したこと

webサイト(https://techacademy.jp/magazine/4630)で見た"gem install rails"と本(HerokuではじめるRailsプログラミング入門)で見た"sudo gem install rails"を試した結果です。
目的はmacにrails が正常にインストールされることです。
いいサイトや方法がありましたらご教授いただけると嬉しいです。

補足情報(言語/FW/ツール等のバージョンなど)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

+1

ERROR:以下の
文を読んでください。
読めない場合はgoogle翻訳で翻訳してみてください
以下google翻訳の結果
レールの取り付け中にエラーが発生しました:
activesupportにはRubyバージョン2.2.2以上が必要です。

プログラムはエラーコードとの戦いです。エラーコードはちゃんと読みましょう。
初心者マークをつけるともっと優しい回答が来るかもしれません

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/01/31 22:55

    解決しました。
    ありがとうございます。

    キャンセル

0

参考情報

Mac に標準で入っている ruby は古いです。
従って まずは 新しい version の ruby のインストールをすることから始めることが必要です。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/01/31 23:12

    ありがとうございます。
    参考にさせていただきます。

    キャンセル

0

macのrubyのバージョンが古いです。
解決するためには以下の手順を終えればいいです。

  1. 下のコマンドを実行し,rubyのインストール先を確認します。
    このコマンドを実行した時,仮に「/usr/local/bin/ruby」と表示されたとします。
    which ruby

  2. rm -rf /usr/local/bin/ruby
    上の「/usr/local/bin/ruby」は,自分の結果に置き換えてください。

  3. macに標準で入ってる,brewコマンドを使い,Rubyを再インストールします。
    3-1. 下のコマンドを実行して,brewコマンドを実行する準備をします。また,パスワードが求められたら入力してください。
    sudo brew update
    3-2. 下のコマンドを実行して,Rubyをインストールします。
    sudo brew install ruby

  4. Terminalを再起動してください。

  5. を実行して,Versionが新しくなっていたら成功です。
    ruby -v

とても,適当な回答で申し訳有りません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7653questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7260questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • MacOS(OSX)

    1902questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。