質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.49%

  • Ruby

    7910questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2455questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

【Ruby on Rails 4】rails new myappでつまづきました。

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,099

HirotoTakaki

score 1




ドットインストールさんにてRails入門の真っただ中ですが、早くもつまづいてしまいました。

リンク先の動画のように

rails new app

を実行させたのですが、以下のメッセージが出てきてしまい、次のステップへ進めません。
どのようにすればよいのでしょうか?

         run  bundle install
DL is deprecated, please use Fiddle
Fetching gem metadata from https://rubygems.org/..........
Resolving dependencies...
Using rake 10.4.2
Using i18n 0.7.0

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    c:/ruby21/bin/ruby.exe -r ./siteconf20150208-7680-1pbq3p.rb extconf.rb
creating Makefile

make "DESTDIR=" clean

make "DESTDIR="
generating generator-i386-mingw32.def
compiling generator.c
make: gcc: Command not found
make: *** [generator.o] Error 127

make failed, exit code 2

Gem files will remain installed in c:/ruby21/lib/ruby/gems/2.1.0/gems/json-1.8.2
 for inspection.
Results logged to c:/ruby21/lib/ruby/gems/2.1.0/extensions/x86-mingw32/2.1.0/jso
n-1.8.2/gem_make.out
An error occurred while installing json (1.8.2), and Bundler cannot continue.
Make sure that gem install json -v '1.8.2' succeeds before bundling.

 
最後の行の

gem install json -v

も実行してみましたが、

ERROR:  While executing gem ... (OptionParser::MissingArgument)
    missing argument: -v

このようなエラーが出てきて、何をしたら良いかわかりません。

初めてプログラミングを試みているので、暗中模索の状態です。
どなたか助けていただければ幸いです。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+3

Windowsで作業されているようですが、Devkitはインストールされましたでしょうか。
Windowsの場合は、こちらからDevelopment Kitをインストールしないと使えないようです。
詳しい手順は「windows rails インストール」などで調べてみてください。

ちなみにRubyとかRailsはあんまりwindowsでの環境構築が難しい印象です(変なところでハマったりしがち)。MacかLinux系の仮想環境(CentOSやUbuntuなど)で作業された方が、よいかもです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/02/09 14:35

    回答ありがとうございます。
    DevKitをインストール済ですが、再び同じエラーメッセージが出てきてしまいました。

    環境を変えることも視野に入れて、もう少し辛抱して続けてみます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7910questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 4

    2455questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。