質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • AWS(Amazon Web Services)

    2000questions

    Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

  • Laravel

    665questions

    LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。

AWSにてlaraval環境構築

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 510

rikoda

score 7

aws無料利用枠でLaravelの環境を構築しようとしていたところ、以下のようなエラーが出ており、困っております。

composer global require "laravel/installer"
Changed current directory to /home/ec2-user/.composer
Using version ^1.3 for laravel/installer
./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • laravel/installer v1.3.0 requires guzzlehttp/guzzle ~4.0|~5.0|~6.0 -> satisfiable by guzzlehttp/guzzle[4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2].
  • laravel/installer v1.3.1 requires guzzlehttp/guzzle ~4.0|~5.0|~6.0 -> satisfiable by guzzlehttp/guzzle[4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2].
  • laravel/installer v1.3.2 requires guzzlehttp/guzzle ~4.0|~5.0|~6.0 -> satisfiable by guzzlehttp/guzzle[4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2].
  • laravel/installer v1.3.3 requires guzzlehttp/guzzle ~4.0|~5.0|~6.0 -> satisfiable by guzzlehttp/guzzle[4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2].
  • laravel/installer v1.3.4 requires guzzlehttp/guzzle ~4.0|~5.0|~6.0 -> satisfiable by guzzlehttp/guzzle[4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2].
  • guzzlehttp/guzzle 6.2.2 requires php >=5.5 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.2.1 requires php >=5.5 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.2.0 requires php >=5.5.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.1.1 requires php >=5.5.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.1.0 requires php >=5.5.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.0.2 requires php >=5.5.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.0.1 requires php >=5.5.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 6.0.0 requires php >=5.5.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.3.1 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.3.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.2.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.0.3 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.0.2 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.0.1 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 5.0.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.2.4 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.2.3 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.2.2 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.2.1 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.2.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.8 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.7 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.6 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.5 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.4 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.3 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.2 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.1 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.1.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.0.2 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.0.1 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • guzzlehttp/guzzle 4.0.0 requires php >=5.4.0 -> your PHP version (5.3.29) does not satisfy that requirement.
  • Installation request for laravel/installer ^1.3 -> satisfiable by laravel/installer[v1.3.0, v1.3.1, v1.3.2, v1.3.3, v1.3.4].

Installation failed, deleting ./composer.json.

phpは以下のバージョンです。
PHP 5.3.29 (cli) (built: May 12 2015 22:42:19)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2014 Zend Technologies

よろしくお願いいたします

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

+1

エラーメッセージは読みましたか?
内容は理解しましたか?

PHPのバージョンが低いって言われてるので、PHPのバージョンを上げればよいと思います。

「aws php 5.6 インストール」とかで検索

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/01/14 17:17

    ありがとうございます!申し訳ございませんが、スコアが低い方をベストアンサーとさせていただきました。感謝致します、

    キャンセル

checkベストアンサー

0

laravelはインストールできていて、composer installを実行しようとしているとお見受けします。

guzzlehttp/guzzle 6.2.2 requires php >=5.5 -> your PHP version (5.3.29) does not satisfy that requirement.


上記のエラーメッセージは、
「composerでインストールしようとしている、guzzle(ライブラリーのことです)はphp5.5以上が必要です。あなたのPHPのversionは5.3.29なので、この条件に満たしていません。」
という旨のエラーメッセージです。

なので他の回答者様の言う通り、PHPのバージョンを5.5以上に上げてから再度トライしてみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • AWS(Amazon Web Services)

    2000questions

    Amazon Web Services (AWS)は、仮想空間を機軸とした、クラスター状のコンピュータ・ネットワーク・データベース・ストーレッジ・サポートツールをAWSというインフラから提供する商用サービスです。

  • Laravel

    665questions

    LaravelとはTaylor Otwellによって開発された、オープンソースなPHPフレームワークです。Laravelはシンプルで表現的なシンタックスを持ち合わせており、ウェブアプリケーション開発の手助けをしてくれます。