質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.50%

Python3環境にscipyがインストールできない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 4,274

RieMatsui

score 21

Python3でのscipyがインストールできません

機械学習のscikit-learn勉強を始めるためにscipyをインストールしてますが、numpyに関してはインストールできたのですが、scipyをインストールする際にはエラーが発生してしまいます。今現在VirtualBoxにCentOS6をインストールしており、Python 3.3.2です。

発生している問題・エラーメッセージ

pip install scipyを実行すると

Command "/opt/rh/python33/root/usr/bin/python -u -c "import setuptools, tokenize;file='/tmp/pip-build-jlki0_/scipy/setup.py';f=getattr(tokenize, 'open', open)(file);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, file, 'exec'))" install --record /tmp/pip-xbf5ll-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-jlki0_/scipy/
と出てしまい、インストールできません

pip install scipy

試したこと

pip install wheel で Wheelをインスートルしましたがインスートルできませんでした。
scikit-learnをインスートルしているので
Pythonを起動し
from sklearn import datasetsを実行、実行結果は

>>> from sklearn import datasets
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/opt/rh/python33/root/usr/lib64/python3.3/site-packages/sklearn/__init__.py", line 57, in <module>
    from .base import clone
  File "/opt/rh/python33/root/usr/lib64/python3.3/site-packages/sklearn/base.py", line 10, in <module>
    from scipy import sparse
ImportError: No module named 'scipy'


となり、インスートルはされていない状態です。

補足情報(言語/FW/ツール等のバージョンなど)

Cent OS6.7
python3.3
pip  pip 9.0.1 from /opt/rh/python33/root/usr/lib/python3.3/site-packages (python 3.3)
numpy  '1.11.3'

何か情報などありましたらご教授願います。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

+2

http://www.task-notes.com/entry/20151116/1447642800
このサイトを参考に

[root@localhost vagrant]#wget https://3230d63b5fc54e62148e-c95ac804525aac4b6dba79b00b39d1d3.ssl.cf1.rackcdn.com/Anaconda3-2.4.0-Linux-x86_64.sh

[root@localhost vagrant]#sh Anaconda3-2.4.0-Linux-x86_64.sh

 
を実施し、単独でインストールは不可でしたが、Anacondaでパッケージをインストールしたら解決しました。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る