質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.03%

【Ruby】PSD.rbのインストールについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,197
退会済みユーザー

退会済みユーザー

前提・実現したいこと

PSDファイルをpngに変換したい。このように考えて、色々調べているとPSD.rbというものが存在しているということを知りました。ここを参考にインストールしてみたのですがrequire'psd'をするとエラーが発生します。もしPSD.rbが動いている方がいらっしゃたらその環境を教えてほしいです。

発生している問題・エラーメッセージ

C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- nokogiri/2.2/nokogiri (LoadError)
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/Ruby22/lib/ruby/gems/2.2.0/gems/nokogiri-1.5.11-x86-mingw32/lib/nokogiri/nokogiri.rb:1:in `<top (required)>'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/Ruby22/lib/ruby/gems/2.2.0/gems/nokogiri-1.5.11-x86-mingw32/lib/nokogiri.rb:28:in `<top (required)>'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:133:in `require'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:133:in `rescue in require'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:40:in `require'
        from C:/Ruby22/lib/ruby/gems/2.2.0/gems/xmp-0.2.0/lib/xmp.rb:2:in `block in <top (required)>'
        from C:/Ruby22/lib/ruby/gems/2.2.0/gems/xmp-0.2.0/lib/xmp/silencer.rb:6:in `silently'
        from C:/Ruby22/lib/ruby/gems/2.2.0/gems/xmp-0.2.0/lib/xmp.rb:2:in `<top (required)>'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from C:/Ruby22/lib/ruby/gems/2.2.0/gems/psd-3.8.0/lib/psd.rb:4:in `<top (required)>'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:133:in `require'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:133:in `rescue in require'
        from C:/Ruby22/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:40:in `require'
        from test584.rb:1:in `<main>'

該当のソースコード

require'psd'

試したこと

現在も継続して解決方法を調べているところです。
nokogiri newer version not supported #95を見てみるとnokogiriのバージョンが新しすぎると動かないようだったのでnokogiriのバージョンを1.5.11にしてみました。

補足情報(言語/FW/ツール等のバージョンなど)

Windows10 64bit
Ruby 2.2.6 32bit
psd 3.8.0

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

自己解決できました。
PSD.rbのうち1.3.3をインストールしたら動きました。
nokogiriのバージョンは関係なかった?みたいです。
インストールする際にはDevkitが求められるので
Rubyの公式サイトから手に入れて
DEVELOPMENT KIT のセットアップ方法
を参考にインストールすると良いと思われます。

私が試して動いたバージョン(Ruby  2.2.6)

1.3.3
1.4.0
1.5.0
2.0.0
3.1.2


この他にも動く組み合わせがあるかもしれません。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る