質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.20%

file_get_contentsでSSLエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 6,278

kunai

score 5185

PHP 7.0.11
CakePHP 2.8.9
CentOS7
Apache 2.4.23

の環境でサイトを運用しております。
システム開発の経験は多いですが、サーバ側の設定等は専門ではありません。

file_get_contentsでgoogleのカレンダー情報を取得している処理の中で、SSLエラーが発生しています。

: file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed

: file_get_contents() []: Failed to enable crypto

エラーを見る限り、SSL v3で接続しようとしているのを拒絶されているのかなと思い、file_get_contents前にプロトコル指定をしております。

$url = "https://www.googleapis.com/calendar/v3/calendars/{$calendar_id}/events?key={$apiKey}&timeMin={$start}&timeMax={$finish}&maxResults=50&orderBy=startTime&singleEvents=true";

$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLS_CLIENT,
    ],
]);
$results = file_get_contents($url, true, $ctx);

しかし、状況は変わらず、同じエラーが表示されてしまいます。

サーバ自体もSSLv3は使わないように設定はしているのですが。。

#httpd.conf
SSLProtocol -All +TLSv1 +TLSv1.1 +TLSv1.2
$ echo x | openssl s_client -ssl3 -connect example.com:443 | grep sslv3
140014322869952:error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure:s3_pkt.c:1472:SSL alert number 40
140014322869952:error:1409E0E5:SSL routines:ssl3_write_bytes:ssl handshake failure:s3_pkt.c:656:

そもそもアプローチの仕方から間違っているようにも思えて来ておりお手上げな状態です、こちらで相談させて下さい。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

get_file_contents()でエラーが出ているので、apacheではないと思います。
CentOSであればopensslのパッケージにCA証明書が含まれているので、opensslを最新の物にアップデートすると直るかもしれません。

sudo yum update openssl

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/19 18:36

    CA証明書が古い可能性がある、と言う事ですかね。
    確かにあるかも知れません。
    このサーバ環境ではPHP7+HTTP2に対応する為、Opensslはyumを使わず手動でmakeしたモノを使っております。
    別環境でyumから取得したbundleと比較してみます。

    キャンセル

  • 2016/12/20 15:26

    ca-bundle.crtファイルを更新したところ、正常に通信できました。
    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.20%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる