質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.79%

  • Ruby

    4315questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    4080questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    1966questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • RubyGems

    222questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

rails capybara-webkit がgemにinstallできない

受付中

回答 1

投稿 2016/12/18 11:46 ・編集 2016/12/18 11:47

  • 評価
  • クリップ 0
  • VIEW 299

SigenSakiyama

score 36

gemfileにcapybara-webkitを追加し、 
bundle install をした後に下記のようなエラーが出ます。 
Errno::EACCES: Permission denied @ rb_sysopen - /Users/shtaarddy9183/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/capybara-webkit-1.11.1/.gitignore 
An error occurred while installing capybara-webkit (1.11.1), and Bundler cannot continue. 
Make sure that gem install capybara-webkit -v '1.11.1' succeeds before bundling.

調べて色々やってみたのですが、できませんでした。。
解決方法があれば教えてください!

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

この前、自分もcapybara-webkitを導入してはまりました。
エラーの内容が違うのが気になりますが、自分が導入するためにやった手順を以下に記載します。

# qtをインストールする為に、g++が必要。
yum -y install gcc-c++

# qtのインストール
yum -y install qt5-qtwebkit-devel

# Capybara-webkitインストール時に使うqmakeコマンドの場所を指定
export QMAKE=/usr/lib64/qt5/bin/qmake

# Gemfileにて、Capybara-webkitのインストール
bundle install


もし、qtが入っていないのでしたら、この手順を試してみてください。
ちなみに、初めてCapybara-webkitを導入する時は、結構時間かかるので、
bundle install中になかなか応答返ってこなくても、ちょっと待ってあげてください。

投稿 2016/12/19 18:47

編集 2016/12/19 18:59

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    以下のような回答は評価を下げられます

    • 間違っている回答
    • 質問の回答になっていない投稿
    • 不快な投稿

    評価を下げる際はその理由をコメントに書き込んでください。

  • 2016/12/20 00:04

    yum -y install gcc-c++
    コマンドを実施すると、-bash: yum: command not found
    となります。
    mac なのですが、yum コマンドができません、、

    キャンセル

  • 2016/12/20 10:30

    あー、ごめんなさい。
    Mac使ってるんですね。(どうりでエラーの内容に見覚えがないと思った。。。)
    でも、qtを入れなきゃいけいのは一緒なので、
    http://qiita.com/akito19/items/40f576ff4a90e9fad008#%E5%AF%BE%E5%BF%9C-3
    を参考に入れてみたら、どうでしょう?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.79%

関連した質問

同じタグがついた質問を見る

  • Ruby

    4315questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    4080questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 4

    1966questions

    Ruby on Rails4はRubyによって書かれたオープンソースのウェブフレームワークです。 Ruby on Railsは「設定より規約」の原則に従っており、効率的に作業を行うために再開発を行う必要をなくしてくれます。

  • RubyGems

    222questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

閲覧数の多いRubyの質問