質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.96%

rails g devise:install でのエラーについて

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 5,545

score 7

gemfileにdeviseを書き込んで、bundle installもした上で下記のエラーが出てdeviseのインスタールがうまくいきません。

発生している問題・エラーメッセージ

Running via Spring preloader in process 1968
Expected string default value for '--helper'; got true (boolean)
Expected string default value for '--jbuilder'; got true (boolean)
Expected string default value for '--rc'; got false (boolean)
Expected string default value for '--helper'; got true (boolean)
Expected string default value for '--assets'; got true (boolean)
Expected string default value for '--rc'; got false (boolean)
Could not find generator 'devise:install'. Maybe you meant 'coffee:assets' or 'js:assets' or 'generator'
Run rails generate --help for more options.
```

該当のソースコード

rails g devise:install

試したこと

Vim Gemfileをターミナルで実行してみたらdevise自体が見当たりませんでした。ただGemfile.lockにはdevise(3.5.2)があります。
初心者なので困っております。宜しくお願い申し上げます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • ironsand

    2016/12/21 07:42

    `bundle install | grep devise` は何が出ますか?

    キャンセル

  • taisho

    2016/12/21 23:18

    ご連絡ありがとうございました。打ち込みましたが特に何も表示は返ってこないです。おそらくdeviseがGemfileに読み込めていないのかもしれません。ただ確認してもGemfileにはgem 'devise'の記述が確かにありますが・・

    キャンセル

  • ironsand

    2016/12/21 23:55

    う〜ん、原因がわからないですね。一度 rails new で別のプロジェクトを作ってみてそちらでも同じエラーが出るか確認すれば何か手がかりが見つかるかもしれません。

    キャンセル

  • taisho

    2016/12/22 22:30

    再度やり直しを何度かしまして無事にクリアすることができました。ありがとうございました!

    キャンセル

回答 3

+1

bundle exec spring stopしてから実行してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

checkベストアンサー

0

bundle exec rails g devise:install

ではどうでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/20 23:20

    ご回答誠にありがとうございます。こちらでも全く同じエラーメッセージが表示されました。。

    キャンセル

0

Vim Gemfileをターミナルで実行してみたらdevise自体が見当たりませんでした。

ということなので、もう一度Gemfileに
gem 'devise'
を書き込んで、bundle installしてみると良いと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/18 17:16

    回答ありがとうございました。
    何度トライしてみても同じエラーとなってしまいます。
    gem 'devise', '1.0.7'などバージョン指定は必要なのでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.96%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る