質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

windowsで環境を整えたvagrant上のcentosの画面のログがうまく表示されない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 923

score 143

現在windowsにてvagrant上にcentosを構築環境として開発し始めました
ところが、catやmore、viなどファイルの中身を見ようとするとおかしなひょうじになります

例えば、以下の文章が

GEM
  remote: https://rubygems.org/
  specs:
    aasm (3.3.1)
    actionmailer (4.2.2)
      actionpack (= 4.2.2)
      actionview (= 4.2.2)
      activejob (= 4.2.2)
      mail (~> 2.5, >= 2.5.4)
      rails-dom-testing (~> 1.0, >= 1.0.5)
    actionpack (4.2.2)
      actionview (= 4.2.2)
      activesupport (= 4.2.2)
      rack (~> 1.6)
      rack-test (~> 0.6.2)
      rails-dom-testing (~> 1.0, >= 1.0.5)
      rails-html-sanitizer (~> 1.0, >= 1.0.1)
    actionview (4.2.2)
      activesupport (= 4.2.2)
      builder (~> 3.1)
      erubis (~> 2.7.0)
      rails-dom-testing (~> 1.0, >= 1.0.5)
      rails-html-sanitizer (~> 1.0, >= 1.0.1)
    active_attr (0.9.0)
      activemodel (>= 3.0.2, < 5.1)
      activesupport (>= 3.0.2, < 5.1)
    activejob (4.2.2)
      activesupport (= 4.2.2)
      globalid (>= 0.3.0)
    activemodel (4.2.2)
      activesupport (= 4.2.2)
      builder (~> 3.1)
    activerecord (4.2.2)
      activemodel (= 4.2.2)
      activesupport (= 4.2.2)
      arel (~> 6.0)
    activesupport (4.2.2)
      i18n (~> 0.7)
      json (~> 1.7, >= 1.7.7)
      minitest (~> 5.1)
      thread_safe (~> 0.3, >= 0.3.4)
      tzinfo (~> 1.1)
    addressable (2.5.0)
      public_suffix (~> 2.0, >= 2.0.2)
    airbrussh (1.1.1)
      sshkit (>= 1.6.1, != 1.7.0)
    ansi (1.5.0)
    arel (6.0.3)
    autoparse (0.3.3)
      addressable (>= 2.3.1)
      extlib (>= 0.9.15)
      multi_json (>= 1.0.0)
    awesome_nested_set (3.1.1)
      activerecord (>= 4.0.0, < 5.1)
    bcrypt (3.1.7-x86-mingw32)
    bootstrap-sass (3.2.0.0)
      sass (~> 3.2)
    bootstrap-will_paginate (0.0.10)
      will_paginate
    breadcrumbs_on_rails (3.0.1)
    builder (3.2.2)
    capistrano (3.7.0)
      airbrussh (>= 1.0.0)
      capistrano-harrow
      i18n
      rake (>= 10.0.0)
      sshkit (>= 1.9.0)
    capistrano-bundler (1.2.0)
      capistrano (~> 3.1)
      sshkit (~> 1.2)
    capistrano-harrow (0.5.3)
    capistrano-rails (1.2.0)
      capistrano (~> 3.1)
      capistrano-bundler (~> 1.1)
    capistrano-rbenv (2.1.0)
      capistrano (~> 3.1)
      sshkit (~> 1.3)
    capistrano-safe-deploy-to (1.1.1)
      capistrano (>= 3.0)
    carrierwave (0.11.2)
      activemodel (>= 3.2.0)
      activesupport (>= 3.2.0)
      json (>= 1.7)
      mime-types (>= 1.16)
      mimemagic (>= 0.3.0)
    chartkick (2.2.1)
    ckeditor (4.2.0)
      cocaine
      orm_adapter (~> 0.5.0)
    climate_control (0.0.3)
      activesupport (>= 3.0)
    cocaine (0.5.8)
      climate_control (>= 0.0.3, < 1.0)
    coderay (1.1.1)
    coffee-rails (4.1.0)
      coffee-script (>= 2.2.0)
      railties (>= 4.0.0, < 5.0)
    coffee-script (2.4.1)
      coffee-script-source
      execjs
    coffee-script-source (1.11.1)
    commonjs (0.2.7)
    concurrent-ruby (1.0.2)
    devise (4.2.0)
      bcrypt (~> 3.0)
      orm_adapter (~> 0.1)
      railties (>= 4.1.0, < 5.1)
      responders
      warden (~> 1.2.3)
    devise-bootstrap-views (0.0.9)
    devise-i18n (1.1.1)
    devise-i18n-views (0.3.7)
    erubis (2.7.0)
    execjs (2.7.0)
    extlib (0.9.16)
    faraday (0.9.2)
      multipart-post (>= 1.2, < 3)
    ffi (1.9.14-x86-mingw32)
    formatador (0.2.5)
    globalid (0.3.7)
      activesupport (>= 4.1.0)
    google-analytics-rails (1.1.0)
    google-api-client (0.7.0)
      addressable (>= 2.3.2)
      autoparse (>= 0.3.3)
      extlib (>= 0.9.15)
      faraday (>= 0.9.0)
      jwt (>= 0.1.5)
      launchy (>= 2.1.1)
      multi_json (>= 1.0.0)
      signet (>= 0.5.0)
      uuidtools (>= 2.1.0)
    gretel (3.0.9)
      rails (>= 3.1.0)
    guard (2.14.0)
      formatador (>= 0.2.4)
      listen (>= 2.7, < 4.0)
      lumberjack (~> 1.0)
      nenv (~> 0.1)
      notiffany (~> 0.0)
      pry (>= 0.9.12)
      shellany (~> 0.0)
      thor (>= 0.18.1)
    guard-minitest (2.3.1)
      guard (~> 2.0)
      minitest (>= 3.0)
    hashie (3.4.6)
    i18n (0.7.0)
    impressionist (1.5.2)
      nokogiri (~> 1.6)
    jbuilder (2.2.3)
      activesupport (>= 3.0.0, < 5)

      actionmailer (= 4.2.2)
      actionpack (= 4.2.2)
      actionview (= 4.2.2)
      activejob (= 4.2.2)
      activemodel (= 4.2.2)
      activerecord (= 4.2.2)
      activesupport (= 4.2.2)
      bundler (>= 1.3.0, < 2.0)
      railties (= 4.2.2)
      sprockets-rails
    rails-deprecated_sanitizer (1.0.3)
      activesupport (>= 4.2.0.alpha)
    rails-dom-testing (1.0.7)
      activesupport (>= 4.2.0.beta, < 5.0)
      nokogiri (~> 1.6.0)
      rails-deprecated_sanitizer (>= 1.0.1)
    rails-html-sanitizer (1.0.3)
      loofah (~> 2.0)
    rails_12factor (0.0.2)
      rails_serve_static_assets
      rails_stdout_logging
    rails_serve_static_assets (0.0.5)
    rails_stdout_logging (0.0.5)
    railties (4.2.2)
      actionpack (= 4.2.2)
      activesupport (= 4.2.2)
      rake (>= 0.8.7)
      thor (>= 0.18.1, < 2.0)
    rake (12.0.0)
    ransack (1.8.2)
      actionpack (>= 3.0)
      activerecord (>= 3.0)
      activesupport (>= 3.0)
      i18n
      polyamorous (~> 1.3)
    rb-fsevent (0.9.8)
    rb-inotify (0.9.7)
      ffi (>= 0.5.0)
    rdoc (4.3.0)
    responders (2.3.0)
      railties (>= 4.2.0, < 5.1)
    retriable (2.1.0)
    ruby-progressbar (1.8.1)
    ruby_dep (1.5.0)
    sass (3.4.22)
    sass-rails (5.0.2)
      railties (>= 4.0.0, < 5.0)
      sass (~> 3.1)
      sprockets (>= 2.8, < 4.0)
      sprockets-rails (>= 2.0, < 4.0)
      tilt (~> 1.1)
    sdoc (0.4.0)
      json (~> 1.8)
      rdoc (~> 4.0, < 5.0)
    shellany (0.0.1)
    signet (0.7.3)
      addressable (~> 2.3)
      faraday (~> 0.9)
      jwt (~> 1.5)
      multi_json (~> 1.10)
    slop (3.6.0)
    sprockets (3.7.0)
      concurrent-ruby (~> 1.0)
      rack (> 1, < 3)
    sprockets-rails (3.2.0)
      actionpack (>= 4.0)
      activesupport (>= 4.0)
      sprockets (>= 3.0.0)
    sshkit (1.11.4)
      net-scp (>= 1.1.2)
      net-ssh (>= 2.8.0)
    thor (0.19.4)
    thread_safe (0.3.5)
    tilt (1.4.1)
    transpose (0.0.1)
      activesupport
    turbolinks (2.3.0)
      coffee-rails
    twitter-bootstrap-rails (3.2.2)
      actionpack (>= 3.1)
      execjs (>= 2.2.2, >= 2.2)
      less-rails (>= 2.5.0)
      railties (>= 3.1)
    tzinfo (1.2.2)
      thread_safe (~> 0.1)
    uglifier (2.5.3)
      execjs (>= 0.3.0)
      json (>= 1.8.0)
    uuidtools (2.1.5)
    warden (1.2.6)
      rack (>= 1.0)
    will_paginate (3.0.7)

PLATFORMS
  x86-mingw32

DEPENDENCIES
  aasm (= 3.3.1)
  active_attr
  awesome_nested_set
  bcrypt (= 3.1.7)
  bootstrap-sass (= 3.2.0.0)
  bootstrap-will_paginate (= 0.0.10)
  breadcrumbs_on_rails
  capistrano
  capistrano-bundler
  capistrano-rails
  capistrano-rbenv
  capistrano-safe-deploy-to (~> 1.1.1)
  carrierwave
  chartkick
  ckeditor
  coffee-rails (= 4.1.0)
  devise
  devise-bootstrap-views
  devise-i18n
  devise-i18n-views
  google-analytics-rails
  google-api-client (= 0.7)
  gretel
  guard-minitest (= 2.3.1)
  impressionist
  jbuilder (= 2.2.3)
  jcrop-rails-v2
  jquery-rails (= 4.0.3)
  jquery-selection-rails
  jquery-turbolinks
  jquery-ui-rails
  kaminari
  mini_backtrace (= 0.1.3)
  mini_magick
  minitest-reporters (= 1.0.5)
  nokogiri
  omniauth
  omniauth-facebook
  omniauth-github
  omniauth-google-oauth2
  omniauth-hatena
  omniauth-linkedin
  omniauth-mixi
  omniauth-twitter
  pace-rails
  rails (= 4.2.2)
  rails_12factor (= 0.0.2)
  ransack
  retriable
  rmagick
  sass-rails (= 5.0.2)
  sdoc (= 0.4.0)
  signet
  therubyracer
  transpose
  turbolinks (= 2.3.0)
  twitter-bootstrap-rails
  uglifier (= 2.5.3)
  unicorn
  will_paginate (= 3.0.7)

BUNDLED WITH
   1.12.5


途切れた文章
下の部分までしか出力されなかったりとログが異常な出力となっています
どうすれば出力が全て出るようになりますか?

12/14追加
途切れた文章

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • A.Ichi

    2016/12/14 11:04

    export TERM=cygwin で成功されたのケースはありましたが。。。

    キャンセル

  • VerfolgungEin

    2016/12/14 12:12

    だめですね・・・投稿を修正して追加した画像のようになります

    キャンセル

  • VerfolgungEin

    2016/12/14 12:14

    それから、echo $TERM cygwinになりました

    キャンセル

回答 1

check解決した方法

0

windowsコンソールからteratermコンソールに切り替えることで解決しました
参考文献の通りteratermからvagrantへssh接続することで起動し、かつcatコマンドでファイルの内容を「全て」閲覧することが可能となりました

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る