質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.03%

MySQLiが無いと怒られたのでインストールしようとしていますがエラーになる

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,789

hidepon

score 181

CentOS7 
MySQL5.7
PHP 7.0.13
Apache 2.4の構成でサーバ構築をしようとしています。

yum info mysql-community-server
yum -y install mysql-community-server
yum --enablerepo=remi-php70 update
yum -y install php-mysqli
を実行したところ下記のエラーが出ました。

Error: Package: php-mysqlnd-5.4.16-36.3.el7_2.x86_64 (updates)
           Requires: php-pdo(x86-64) = 5.4.16-36.3.el7_2
           Installed: php-pdo-7.0.13-1.el7.remi.x86_64 (@remi-php70)
               php-pdo(x86-64) = 7.0.13-1.el7.remi
           Available: php-pdo-5.4.16-36.el7_1.x86_64 (base)
               php-pdo(x86-64) = 5.4.16-36.el7_1
           Available: php-pdo-5.4.16-36.1.el7_2.1.x86_64 (updates)
               php-pdo(x86-64) = 5.4.16-36.1.el7_2.1
           Available: php-pdo-5.4.16-36.3.el7_2.x86_64 (updates)
               php-pdo(x86-64) = 5.4.16-36.3.el7_2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


これはどのように対処すればよいのでしょうか?
前のバージョンの話をされているようなので、回避が必要でしょうか?
宜しくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

Error: Package: php-mysqlnd-5.4.16-36.3.el7_2.x86_64 (updates)

→ パッケージエラー: updates レポジトリから php-mysqlnd-5.4.16-36.3.el7_2.x86_64 をインストールすること

Requires: php-pdo(x86-64) = 5.4.16-36.3.el7_2

→ 依存関係: php-pdo(x86-64) の 5.4.16-36.3.el7_2 バージョン

Installed: php-pdo-7.0.13-1.el7.remi.x86_64 (@remi-php70)

→ remi-php70レポジトリから php-pdo-7.0.13-1.el7.remi.x86_64 がすでにインストールされている


yum install php-mysqlnd

とレポジトリを指定せずにインストールしようとすると、デフォルトで有効化されていないレポジトリからのインストールは行われません。つまり remi-php70 からのインストールはされないという状態です。

--enablerepo=remi-php70 をつけて実行するか、/etc/yum.repod/remi-php70.repo ファイルを編集し、enabled=1 にして実行することで、インストールできるようになります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る