質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.13%

androidプラグインでのエラー対処方法

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 4,446

score 48

ヘルプ → 新規ソフトウェアのインストール → 追加
名前にAndroid Plugin
ロケーションにhttps://dl-ssl.google.com/android/eclipse/
を記入してインストールを開始したところ以下のエラーが出ました

「項目のインストール中にエラーが発生しました
セッション・コンテキスト:(プロファイル=epp.package.jee、フェーズ=org.eclipse.equinox.internal.p2.engine.phases.Install、オペランド=null --> [R]org.eclipse.oomph.base 1.5.0.v20160721-0839、アクション=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction)。
osgi.bundle,org.eclipse.oomph.base,1.5.0.v20160721-0839 のアーティファクト・ファイルが見つかりませんでした。」

調べてみて
https://dl-ssl.google.com/android/eclipse/

http://dl-ssl.google.com/android/eclipse/
に変えてみたり

ウィンドウ → 設定 → インストール/更新 → 使用可能なソフトウェア・サイトの設定を開き、更新できないロケーションを選択し、再ロードをクリックする
などを試したのですがエラーが出てしまいました。

改善するにはどのようにすればいいのでしょうか?
よろしくお願いします。

追記
インストールの際、開発ツールとNDK Pluginsの項目があるみたいなのですが、私のは開発ツールの項目しかありませんでした。
これもエラーに何か関係あるかもしれないので書いておきます

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

どうしてもeclipseを使いたいんだというなら無視してください。

知っていると思いますがADTプラグインのサポートはもう行われていません。
最新のコードの導入方法を書いたサイトのほとんどがAndroidStudioを前提に書かれています。そのためAndroidStudioを使うことをお勧めします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/12/06 09:12

    回答ありがとうございます!
    AndroidStudioでやってみたいと思います

    キャンセル

0

次の2点確認されましたでしょうか
・インストールしている物のバージョンがそろっていない(古いものが混じっている)
・ダウンロードのURLが間違っている

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/28 14:42

    回答ありがとうございます。
    ・インストールしている物のバージョンがそろっていない(古いものが混じっている)
    インストールしている物というのはeclipseなどのことでしょうか?
    Java Platform (JDK) は8u112
    PleiadesはEclipse4.6Neon Pleiades All in One です

    ・ダウンロードのURLが間違っている
    ダウンロードのURLとは何のことでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る