質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.64%

pipとpythonバージョンの関係性について

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,866

Kimsehwa

score 302

docker-syncというものを使いたくインストール中以下のエラーに遭遇しました。

/usr/local/bin/unison-fsmonitor
Traceback (most recent call last):
  File "/usr/local/bin/unison-fsmonitor", line 24, in <module>
    import fsevents
ImportError: No module named fsevents

feventsというのがないらしくpip install macfseventsを実行しましたが、それでも改善できません。(環境はOSXです。)

予測だと私のpythonバージョンは

python -V
Python 3.2

なのにpip install xxすると/usr/local/lib/python2.7/site-packages/
の下にインストールされてるので/usr/local/bin/unison-fsmonitor
実行時にはpython3.2の環境になり、見つからないのではないかと思います。

ls -la /usr/local/bin/pip*すると

-rwxr-xr-x  1 root      staff  301 11 25 15:31 /usr/local/bin/pip
-rwxr-xr-x  1 root      staff  303 11 25 15:31 /usr/local/bin/pip2
-rwxr-xr-x  1 root      staff  307 11 25 15:31 /usr/local/bin/pip2.7
-rwxr-xr-x  1 sehwakim  staff  304 11 25 15:04 /usr/local/bin/pip3
-rwxr-xr-x  1 sehwakim  staff  308 11 25 15:04 /usr/local/bin/pip3.4

いろんなpipがあるようですが、
python 3.2に合わせてpipを再インストールしなければいけないでしょうか?

とりあえずImportError: No module named fsevents
エラーが出なければそれでもよいですが、
できれば綺麗なpython環境の作り方を教えていただきたいです。

以上、宜しくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

下記の部分だけユーザが他のモジュールが違うので
pyenvなどの実行の仮想環境を利用されていませんか?

-rwxr-xr-x  1 sehwakim  staff  304 11 25 15:04 /usr/local/bin/pip3
-rwxr-xr-x  1 sehwakim  staff  308 11 25 15:04 /usr/local/bin/pip3.4

下記の手順をお試しください。

/usr/local/bin/pip3 install macfsevents

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.64%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る