質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.39%

  • Java

    16461questions

    Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

  • Android

    7500questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Xamarin

    658questions

    Xamarin(ザマリン)は、iPhoneなどのiOSやAndroidで動作し、C# 言語を用いてアプリを開発できるクロスプラットフォーム開発環境です。Xamarin Studioと C# 言語を用いて、 iOS と Android の両方の開発を行うことができます。

新規でBlankApp(Xamarin.FormsPortable)プロジェクト作成後、Androidをビルドするとエラーになる

解決済

回答 5

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,043

 環境 

VMwareFusion(仮想環境)にWindows10 64bit版インストール

VisualStudio 2015 Professional

JDKのバージョン 1.8.0_101

 関連スクリーンショット

イメージ説明

イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 5

+1

たぶん JDK1.8 が入ってないですね。
Jdk1.8をインストールして、そのパスを Visual Studio で設定すると解決すると思います。

@ireshika said:
download android JDK1.8 from below location oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
And in Preferences->SDK Locations ->Android change your JDK path to JDK 1.8
This is a version miss match that your compiler is looking for java version 8 and you have java version 7.If you have installed Android studio make sure to set JDK paths separately and if you are installing Android studio after installing tamarin studio ,make sure it doesn't override your JDK version

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/20 18:15

    JDKのバージョンを「1.8.0_101」に変更しましたがビルドエラーは解消されないです。

    キャンセル

  • 2016/11/20 18:34

    そうでしたか…、私も昨日同じ症状に出くわして、その時は 64bit 版の JDK1.8 を入れて、そのパスを設定したら解消しました。

    キャンセル

  • 2016/11/20 18:41 編集

    それってJava SE Development Kit 8u111 or
    Java SE Development Kit 8u112
    どちらですか?

    キャンセル

  • 2016/11/20 18:46

    8u111 の方でしたね。
    「Windows x64 194.64 MB jdk-8u111-windows-x64.exe」
    のやつです。

    キャンセル

+1

こんばんは、
エラーの内容を拝見すると、Hyper-Vが有効になっていないように見受けられます。
Hyper-Vが有効でないため、エミュレータが起動できない状態かと思います。
(VMwareFusionでは、標準の状態だとHyper-Vを有効にできないので、これが原因かと思います。)

以下、VMwareFusion上のWindowsでHyper-Vを有効化するために参考にしていただけそうなリンクです。

・VMware Fusionで作成したWindows 10 Professionalの仮想マシンでHyper-Vを有効化する方法
http://ottan.xyz/vmware-fusion-windows10-hyper-v-4689/

・FUSION 上で HYPER-V を動かしたい
http://www.work-front.com/fusion-上で-hyper-v-を動かしたい/

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

Android のエミュレータには、現在、以下の5種類があります(ありました)。

  1. Android 公式の ARM エミュレータ
  2. Android 公式の HAXM エミュレータ
  3. GenyMotion などサードパーティ製エミュレータ
  4. Visual Studio Emulator
  5. Xamarin Android Player

1 は、最初期からある純正エミュレータで、一般的に「遅い」「Androidのエミュレータは使えない」と言われているものです。
2 は、数年前から用意されている純正の高速エミュレータで「x86 エミュレータ」などとも呼ばれています。HAXM というドライバと VT-x という仮想化技術を使います。
3 は、1. の代わりとして人気のあるエミュレータで VirtualBox の仮想化技術を使います。
4 は、Microsoft が開発したエミュレータ(質問者さんが使われているエミュレータ)で、 T.Miyake さん、 nuits.jp さんが回答されているように Hyper-V という仮想化技術が使われています。
5 は Xamarin 社が開発した VirtualBox によるエミュレータですが、現在はサポート終了となっています。

ただ Hyper-V は他の仮想化技術と併用できないなど不便なことがありますので、
私は、「2. Android 公式の HAXM エミュレータ」を推します。

私も VMWare Fusion のゲストOSとして Windows10 Pro を使っていますが、
HAXM を使うために必要な VT-x は、VMware の設定→プロセッサとメモリ内の下記画像の設定をONにすることで有効化できます。

あとは、Win10 で HAXM エミュレータを作成しますが、 Android Studio を入れて、その手順に従うのが簡単です。

これで、Visual Studio から HAXM エミュレータが起動できます(私はこの流れで VMware Fusion内の Win10 で HAM エミュレータが動いています)。
ただ、 VMware Fusion 内でエミュレータを動かす場合、仮想化の中で仮想化を行うことになるので、十分な速度は得られません。できれば Android 実機を用意した方がよいと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

checkベストアンサー

0

こんにちは。田淵です。
エラーの内容を書くと解決までが早いと思います。

で、おそらく
System.MissingMethodException: Method 'Android.Support.V4.Widget.DrawerLayout.AddDrawerListener' not found.
のエラーが出ていると思います。

最新版のXamarin 4.2.1.162に含まれるXamarin.Formsのテンプレートに不備があり、Xamarin.FormsのAndroidプロジェクトに必要ないくつかのライブラリが含まれていません。

ソリューションを右クリックして、Xamarin.Formsを最新版にアップデートすることで、ビルドが通るようになるはずです。

追記:
ブログ書きました。

【緊急】【拡散希望】最新の Xamarin 4.2.1.162 で作成できる Xamarin.Forms のテンプレートは不備があります - Xamarin 日本語情報

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/23 23:50

    http://ytabuchi.hatenablog.com/entry/2016/11/21/170000
    ↑こちらのブログを参考にAndroidをビルドしてみましたが
    ビルド出来ませんでした
    ビルド失敗後のスクリーンショットを載せておきました。

    キャンセル

  • 2016/11/28 17:55

    皆さん回答しているように、ビルドは通っていて、Visual Studio Emulator for Android が実行できていないだけなので、x86 Emulatorを使えば問題は解決するはずです。Windows 10 が Pro 以上でないと Hyper-V を使用する VS Emu for Android は使えないですね…

    キャンセル

0

エラー画面から推測するに、ビルドは成功してAndroidエミュが起動できず配置出来ていないケースだと思います。
エミュはHyper-V上で動作しますが、Hyper-Vの動作にはCPUの仮想化支援機能が有効になっている必要があります。
そしてVMは通常その機能はデフォルトでオフになっています。
Fusion は使ったことがないため詳細は分かりませんが、仮想マシンの設定のCPU周りにそれらしい設定があると思うので、オンにした後、Hyper-Vをコントロールパネルから入れ直して(二つある内の一つがはずれていふはす)再起動してから試して見てください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.39%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Java

    16461questions

    Javaは、1995年にサン・マイクロシステムズが開発したプログラミング言語です。表記法はC言語に似ていますが、既存のプログラミング言語の短所を踏まえていちから設計されており、最初からオブジェクト指向性を備えてデザインされています。セキュリティ面が強力であることや、ネットワーク環境での利用に向いていることが特徴です。Javaで作られたソフトウェアは基本的にいかなるプラットフォームでも作動します。

  • Android

    7500questions

    Androidは、Google社が開発したスマートフォンやタブレットなど携帯端末向けのプラットフォームです。 カーネル・ミドルウェア・ユーザーインターフェイス・ウェブブラウザ・電話帳などのアプリケーションやソフトウェアをひとつにまとめて構成。 カーネル・ライブラリ・ランタイムはほとんどがC言語/C++、アプリケーションなどはJavaSEのサブセットとAndroid環境で書かれています。

  • Xamarin

    658questions

    Xamarin(ザマリン)は、iPhoneなどのiOSやAndroidで動作し、C# 言語を用いてアプリを開発できるクロスプラットフォーム開発環境です。Xamarin Studioと C# 言語を用いて、 iOS と Android の両方の開発を行うことができます。