質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.00%

macOS SierraでTensorFlowがインストールできない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,278

t3rry

score 6

TensorFlowを使いたい

Python3なTensorFlow環境構築 (Macとpyenv virtualenv)

Python未経験エンジニアがMacでTensorFlowの実行環境+快適なコーディング環境を構築するまで

上記のリンク先を参考に手順どおり実行してみたのですが、上手く動きません。

具体的には、pyenvを用いてpython 2.7.12をインストールしました

$ pyenv versions
  system
* 2.7.12 (set by /Users/username/.pyenv/version)```

その後公式サイトからpython2用の部分をコピーして貼り付け、実行しました。

その結果、正常にインストール出来たかのようなメッセージが出力されるのですが

$ export TF_BINARY_URL=https://storage.googleapis.com/tensorflow/mac/gpu/tensorflow-0.11.0-py2-none-any.whl  
$ sudo -H pip install --upgrade $TF_BINARY_URL --ignore-installed six  
Installing collected packages: six, wheel, funcsigs, pbr, mock, setuptools, protobuf, numpy, tensorflow  
Successfully installed funcsigs-1.0.2 mock-2.0.0 numpy-1.11.2 pbr-1.10.0 protobuf-3.0.0 setuptools-28.8.0 six-1.10.0 tensorflow-0.11.0 wheel-0.29.0

pythonを起動して、tensorflowをインポートしようとすると上手くインポートできません

$ python  
Python 2.7.12 (default, Nov 10 2016, 17:19:32)  
[GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.42.1)] on darwin  
Type "help", "copyright", "credits" or "license" for more information.  
>>> import tensorflow as tf  
Traceback (most recent call last):  
File "<stdin>", line 1, in <module>  
File "/Users/username/.pyenv/versions/2.7.12/lib/python2.7/site-packages/tensorflow/__init__.py", line 23, in <module>  
from tensorflow.python import *  
File "/Users/username/.pyenv/versions/2.7.12/lib/python2.7/site-packages/tensorflow/python/__init__.py", line 49, in <module>  
from tensorflow.python import pywrap_tensorflow  
File "/Users/username/.pyenv/versions/2.7.12/lib/python2.7/site-packages/tensorflow/python/pywrap_tensorflow.py", line 28, in <module>  
_pywrap_tensorflow = swig_import_helper()  
File "/Users/username/.pyenv/versions/2.7.12/lib/python2.7/site-packages/tensorflow/python/pywrap_tensorflow.py", line 24, in swig_import_helper  
_mod = imp.load_module('_pywrap_tensorflow', fp, pathname, description)  
ImportError: dlopen(/Users/username/.pyenv/versions/2.7.12/lib/python2.7/site-packages/tensorflow/python/_pywrap_tensorflow.so, 10): Library not loaded: @rpath/libcudart.8.0.dylib  
Referenced from: /Users/username/.pyenv/versions/2.7.12/lib/python2.7/site-packages/tensorflow/python/_pywrap_tensorflow.so  
Reason: image not found

何が原因で実行できないのか、また、どうすれば解決できるのかを教えて頂きたいです。
よろしくお願いします。

OS環境

macOS Sierra 10.12.1

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

'sudo easy_install --upgrade six'で最新にしてから再度tensorflowをインポートしてみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/10 20:10

    試してみましたが、結果は変わらずです……

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.00%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る