質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.36%

  • Ruby

    5198questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5078questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

railsでサーバー コンソールが起動しなくなりました

解決済

回答 1

投稿 2016/10/18 00:40 ・編集 2016/10/18 01:07

  • 評価
  • クリップ 0
  • VIEW 295

drizzing20

score 346

Gemfileは以下のようになっています

gem 'google-api-client', '~> 0.9.15', :require => 'google/api_client'


さっきまで正常に動いていたのですが
git pull origin master
をしたところそれ以降 
rails s
rails c をしても以下のような表示をされるようになり立ち上がらなくなりました。改善方法がわかる方お願いします。

sample/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `require': cannot load such file -- google/api_client (LoadError)
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `block in require'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:240:in `load_dependency'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.5/lib/active_support/dependencies.rb:274:in `require'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/google_drive-1.0.0/lib/google_drive.rb:5:in `<top (required)>'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler/runtime.rb:91:in `require'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler/runtime.rb:91:in `block (2 levels) in require'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler/runtime.rb:86:in `each'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler/runtime.rb:86:in `block in require'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler/runtime.rb:75:in `each'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler/runtime.rb:75:in `require'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/bundler-1.13.0/lib/bundler.rb:106:in `require'
    from /Users/mypc/project/aaa/sample/config/application.rb:10:in `<top (required)>'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application.rb:82:in `require'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application.rb:82:in `preload'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application.rb:143:in `serve'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application.rb:131:in `block in run'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application.rb:125:in `loop'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application.rb:125:in `run'
    from /Users/mypc/project/aaa/sample/vendor/bundle/ruby/2.3.0/gems/spring-2.0.0/lib/spring/application/boot.rb:19:in `<top (required)>'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /Users/mypc/.rbenv/versions/2.3.1/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from -e:1:in `<main>'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

google-api-clientはGemfileに追加されていますか?
されていなければ、以下のようにGemfileに追加し、bundle installしてみてください。

# Gemfile

 gem 'google-api-client'

追記

以下の指定でどうでしょうか?

gem 'google-api-client', '~> 0.9.15', :require => 'google/api_client'

投稿 2016/10/18 00:50

編集 2016/10/18 01:00

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/18 00:56

    それは入っていました。入れ替えてbundle installしてみましたが同じ文がでてきました。

    キャンセル

  • 2016/10/18 01:01

    追記の指定でbundle installしてみるとどうでしょうか?
    もしそれでダメでしたら、自身でrequireしている箇所のコード等を質問に追記お願いできますか?

    キャンセル

  • 2016/10/18 01:05

    追加してbundle install
    bundle updateしてみましたが変わりませんでした。

    キャンセル

  • 2016/10/18 01:13

    google/apiを使用している箇所のコードはいただけますか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.36%

関連した質問

同じタグがついた質問を見る

  • Ruby

    5198questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5078questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。