質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.55%

ubuntu16.04上にmaharaを導入したい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,056

oor

score 10

前提・実現したいこと

ubuntuでlocalhost上にmaharaを導入したいのですがエラーが発生しました。

発生している問題・エラーメッセージ

http//localhost にアクセスすると

mahara: site unavailable
your server configuration dos not include the xml extension. Sahara requires this in order to parse XML data from a variety of sources. Please make sure that it is loaded in php.ini or install it if it is not installed```  

試したこと

macOSでVirtualBox上でubuntuを起動しています

このサイト(https://www.rosehosting.com/blog/how-to-install-mahara-on-ubuntu/)を 参考に導入を行ったのですが、 mahara.confの設定がわからないです。

現在はmasara.confを下記に変更しました。 localhostにアクセスすると上記のエラーが発生しました。

<VirtualHost *:80>  
ServerAdmin localhost  
DocumentRoot /var/www/html/mahara/htdocs/  
ServerName localhost  
ServerAlias localhost  
<Directory /var/www/html/mahara/htdocs/>  
Options FollowSymLinks  
AllowOverride All  
Order allow,deny  
allow from all  
</Directory>  
ErrorLog /var/log/apache2/your-domain.com-error_log  
CustomLog /var/log/apache2/your-domain.com-access_log common  
</VirtualHost>

補足情報(言語/FW/ツール等のバージョンなど)

ubuntu 16.04 
php5.6?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

php-xml パッケージがインストールされてるか確認してください。
入ってなければ、インストールしてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/17 19:03

    ありがとうございます。
    sudo apt-get install php5.6-xml で解決しました

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.55%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る