rake db:create出来ない

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 771

Miracle

score 52

Rubyの2.3.1をインストールしたあとに、rails newでプロジェクトを作成したのですが、なぜが rake db:createが出来なくて、困っています。

表示されるエラーは以下の通りです。

dyld: lazy symbol binding failed: Symbol not found: _rb_data_typed_object_alloc
  Referenced from: /Users/アカウント名/.rbenv/versions/2.1.3/ruby/gems/2.1.0/gems/gems/debug_inspector-0.0.2/lib/debug_inspector.bundle
  Expected in: flat namespace

dyld: Symbol not found: _rb_data_typed_object_alloc
  Referenced from: /Users/アカウント名/.rbenv/versions/2.1.3/ruby/gems/2.1.0/gems/gems/debug_inspector-0.0.2/lib/debug_inspector.bundle
  Expected in: flat namespace

Trace/BPT trap: 5

そもそものインストール方法としては、
rbenv install 2.3.1
rbenv rehash
gem install bundler
rbenv rehash
rbenv local 2.3.1
という順番で行いました。

どの様な対処法がありますでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hana-da

    2016/10/15 00:57

    記載されているメッセージの前に他のメッセージが出ているようであれば追記してください

    キャンセル

  • Miracle

    2016/10/15 10:30

    特に他のメッセージは記述されていないです。こちらが全てになります。

    キャンセル

回答 2

checkベストアンサー

0

一応rubyのバージョン確認してください。

ruby -vで確認出来ます。

あとは先頭にbundle exec つけたらイケるのでは?

bundle exec rake db:create

もしかして、作るDBの記述をしてないとか・・・?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/15 10:32

    ruby -vで、いかが出力されます。

    ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin15]

    エラーのところで、referenced from ~~~/2.1.3/~~~とありますが、そもそも2.3.1となっていないことに問題があるのでしょうか?

    bundle execを付けても、全く同じエラーが表示されてしまいます。

    キャンセル

0

dyldの環境変数(DYLD_LIBRARY_PATH)に問題があるようです。確認してみてください。
http://easyramble.com/dyld-symbol-not-found.html

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/15 10:39

    こちらをやっても、全く同じエラーが表示されてしまいます。。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる