質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.20%

Ruby on Railsにおけるgemの使用

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 868

nimi0370

score 47

前提・実現したいこと

ruby on railsにおいて、ログイン機能を実装したいと思っています。
まず、Gemfileに
gem 'devise','3.5.1'を入力し、ターミナルにbundle installを入力したところうまくいきません。

発生している問題・エラーメッセージ

$ bundle install
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "railties":
  In snapshot (Gemfile.lock):
    railties (= 5.0.0.1)

  In Gemfile:
    coffee-rails (~> 4.2) was resolved to 4.2.1, which depends on
      railties (< 5.2.x, >= 4.0.0)

    devise (= 3.5.1) was resolved to 3.5.1, which depends on
      railties (< 5, >= 3.2.6)

    jquery-rails was resolved to 4.2.1, which depends on
      railties (>= 4.2.0)

    rails (>= 5.0.0.1, ~> 5.0.0) was resolved to 5.0.0.1, which depends on
      railties (= 5.0.0.1)

    devise (= 3.5.1) was resolved to 3.5.1, which depends on
      responders was resolved to 2.3.0, which depends on
        railties (< 5.1, >= 4.2.0)

    sass-rails (~> 5.0) was resolved to 5.0.6, which depends on
      railties (< 6, >= 4.0.0)

    web-console was resolved to 3.3.1, which depends on
      railties (>= 5.0)

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

試したこと

ここから進みようがなく、まだ何もできていません。

補足情報(言語/FW/ツール等のバージョンなど)

より詳細な情報
・Ruby on rails 2.3.0
・Mac OS X El Capitan 10.11.6

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

deviseは4系列でないとRails 5に対応しません(deviseのCHANGELOG)。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/02 15:20

    具体的な回答ありがとうございます

    キャンセル

0

おそらくrails2.3.0だとdevise3.5.1は使えないのかもしれないです。
軽く調べただけなのであれなんですけど、おそらくrails2.3.0であればdevise1.0.7またはdevise1.0.8なら使えると思います。

Installing devise on Rails 2.3.5

Railsの第4世代認証エンジンDeviseのREADMEを翻訳してみた

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/02 15:20

    わざわざ調べて頂いてありがとうございます!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.20%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる