質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.98%

pythonのモジュールについてのエラー

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,376

u_k_statistics

score 42

pythonで
from sklearn.cluster import KMeans
というコマンドを実行したところ

File "xxxx.py", line 14, in <module>
    from sklearn.cluster import KMeans
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/sklearn/__init__.py", line 57, in <module>
    from .base import clone
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/sklearn/base.py", line 11, in <module>
    from .utils.fixes import signature
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/sklearn/utils/__init__.py", line 10, in <module>
    from .murmurhash import murmurhash3_32
  File "numpy.pxd", line 155, in init sklearn.utils.murmurhash (sklearn/utils/murmurhash.c:5029)
ValueError: numpy.dtype has the wrong size, try recompiling
[Finished in 2.0s with exit code 1]


と出てしまいました。
一応私なりに必要なものはインストールしたつもりなのですが、どこが原因なのでしょうか?
pip listで確認したところ以下の物がインストールされていました。
Benchmarker (4.0.1)
et-xmlfile (1.0.0)
jdcal (1.0)
memory-profiler (0.41)
mysql-connector-python (2.0.4)
numpy (1.11.1)
openpyxl (2.3.0b1)
pandas (0.18.1)
pip (8.1.2)
psutil (4.3.0)
PyMySQL (0.7.6)
python-dateutil (2.5.3)
pytz (2016.6.1)
scikit-learn (0.17.1)
scipy (0.18.0)
setuptools (15.2)
six (1.10.0)
vboxapi (1.0)
xlrd (0.9.4)

またScikit-learnのHP(?)に

Scikit-learn requires:

Python (>= 2.6 or >= 3.3),
NumPy (>= 1.6.1),
SciPy (>= 0.9).

と書いてあったのですが、scipyのバージョンがあっていませんか?
私自身あっていないと思ったので
pip install -U scipy
と実行したのですが
Requirement already up-to-date: scipy in ./site-packages
Requirement already up-to-date: numpy>=1.7.1 in ./site-packages (from scipy)
とでて最新版っぽいです。

その後にhttp://blog.livedoor.jp/riku_kanzaki/archives/2014-10.html
を参考に
$ sudo easy_install -U numpy

$ pip freeze | grep numpy
numpy==1.9.0

$ pip freeze | grep pandas
pandas==0.14.1
を実行しましたが、何をやっているかもわからず、しかも結果は変わりませんでした。

プログラミング初心者で専門用語などわかりませんが、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

ウェブ検索すると、stackoverflowにそのまんまのタイトルで事例がみつかります。

numpyはバージョン間でABIに互換性がないので、numpyをアップグレードするとnumpyを使うモジュールが動かなくなる、ということらしいです。

numpyを使っているモジュール (質問中で示しておられるスタックトレースによれば、今回はsckit-learnでしょうか) を再コンパイル、再インストールしてやれば、アップグレードされたnumpyで動くモジュールになるのではないでしょうか。

$ pip uninstall scikit-learn
$ pip install scikit-learn --no-cache-dir


インストールの際に--no-cache-dirを指定して、確実に再コンパイルされるようにします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.98%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る