質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

postfixのインストールができない

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,546

kumakumatan

score 155

CentOS release 6.5 (Final)
にて「yum install postfix」コマンドを入力すると、

Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.tsukuba.wide.ad.jp
 * epel: ftp.iij.ad.jp
 * extras: ftp.tsukuba.wide.ad.jp
 * ius: ftp.neowiz.com
 * remi-safe: ca.mirror.babylon.network
 * updates: www.ftp.ne.jp
Resolving Dependencies
--> Running transaction check
---> Package postfix.x86_64 2:2.6.6-6.el6_7.1 will be installed
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: 2:postfix-2.6.6-6.el6_7.1.x86_64
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: 2:postfix-2.6.6-6.el6_7.1.x86_64
--> Finished Dependency Resolution
Error: Package: 2:postfix-2.6.6-6.el6_7.1.x86_64 (base)
           Requires: libmysqlclient.so.16()(64bit)
Error: Package: 2:postfix-2.6.6-6.el6_7.1.x86_64 (base)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


と表示されて、インストールできない状況です。

「/etc/yum.conf」を開くと、
exclude=kernel* php* mysql*
と記載されています。
mysqlクライアントが必要な為、mysqlクライアントをインストールしています。

どのようにしたらインストールできるでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • TaichiYanagiya

    2016/09/16 19:56

    他のリポジトリから mysql をインストールしているなどの理由で、/etc/yum.conf で "exclude=mysql*" などと設定していませんでしょうか。

    キャンセル

回答 2

checkベストアンサー

0

IUS リポジトリと remi リポジトリが混在しているのはあまり好ましくないかと思いますが、それぞれ何のパッケージを追加するためにリポジトリを追加されているでしょうか。

とりあえず remi リポジトリが無効なようなので、以下のように実行してみてはどうでしょうか。

yum install postfix --enablerepo=remi

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/20 09:03

    ご回答ありがとうございます。
    インストール後「alternatives -config mta」を実施すると、
    ```
    alternatives version 1.3.49.3 - Copyright (C) 2001 Red Hat, Inc.
    This may be freely redistributed under the terms of the GNU Public License.

    usage: alternatives --install <link> <name> <path> <priority>
    [--initscript <service>]
    [--slave <link> <name> <path>]*
    alternatives --remove <name> <path>
    alternatives --auto <name>
    alternatives --config <name>
    alternatives --display <name>
    alternatives --set <name> <path>

    common options: --verbose --test --help --usage --version
    --altdir <directory> --admindir <directory>
    ```
    と表示されてしまい、
    「/usr/sbin/sendmail.postfix」に「*+1」が付いているのを確認したいのですが
    できないでいます。
    「chkconfig –list postfix」でランレベルを確認したくても、
    ```
    chkconfig version 1.3.49.3 - Copyright (C) 1997-2000 Red Hat, Inc.
    This may be freely redistributed under the terms of the GNU Public License.

    usage: chkconfig [--list] [--type <type>] [name]
    chkconfig --add <name>
    chkconfig --del <name>
    chkconfig --override <name>
    chkconfig [--level <levels>] [--type <type>] <name> <on|off|reset|resetpriorities>
    ```
    と表示されてしまいます。

    「yum list | grep postfix」とすると、
    ```
    postfix.x86_64 2:2.6.6-6.el6_7.1 @base
    pcp-pmda-postfix.x86_64 3.10.9-6.el6 base
    postfix-perl-scripts.x86_64 2:2.6.6-6.el6_7.1 base
    spamass-milter-postfix.noarch 0.3.2-4.el6 epel
    ```
    と表示されるので、postfixのインストールはされていると思われます。
    以上、宜しくお願いします。

    キャンセル

0

エラーメッセージで出てきているように

オプションとして --skip-broken を使用しましたか?
もしくはコマンドとして rpm -Va --nofiles --nodigest を使用しましたか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る