質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.21%

ubuntuでソフトのインストールができない

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 15K+

dlrowolleh

score 120

ubuntu16.04LTSにソフトをインストールしたい

よろしくお願いします。
ソフトをインストールしたいのですが、うまくいきません。
どなたか力を貸してください。

該当のソースコード(コマンド)

$ sudo apt-get install -y w3m vim sl cowsay trash-cli sysvbanner libaa-bin rig bb bb cmatrix firefox indicator-multiload jnethack oneko rain xbill xboing xevil xgal xneko decayscreen greynetic halo helix hopalong hypercube imsmap maze pedal stars xearth xeyes xeyes+ xgc xgolgo xlock xlogo xphoon xroach xscreensaver

発生している問題・エラーメッセージ

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
パッケージ xeyes は使用できませんが、別のパッケージから参照されます。
これは、パッケージが欠落しているか、廃止されたか、または別のソース
からのみ利用可能であることを意味します。
しかし、以下のパッケージが置き換えます:
  x11-apps:i386 x11-apps

パッケージ xgc は使用できませんが、別のパッケージから参照されます。
これは、パッケージが欠落しているか、廃止されたか、または別のソース
からのみ利用可能であることを意味します。
しかし、以下のパッケージが置き換えます:
  x11-apps:i386 x11-apps

パッケージ xlogo は使用できませんが、別のパッケージから参照されます。
これは、パッケージが欠落しているか、廃止されたか、または別のソース
からのみ利用可能であることを意味します。
しかし、以下のパッケージが置き換えます:
  x11-apps:i386 x11-apps

パッケージ xlock は使用できませんが、別のパッケージから参照されます。
これは、パッケージが欠落しているか、廃止されたか、または別のソース
からのみ利用可能であることを意味します。

パッケージ stars は使用できませんが、別のパッケージから参照されます。
これは、パッケージが欠落しているか、廃止されたか、または別のソース
からのみ利用可能であることを意味します。

E: パッケージ jnethack が見つかりません
E: パッケージ rain が見つかりません
E: パッケージ xboing が見つかりません
E: パッケージ xgal が見つかりません
E: パッケージ xneko が見つかりません
E: パッケージ decayscreen が見つかりません
E: パッケージ greynetic が見つかりません
E: パッケージ halo が見つかりません
E: パッケージ helix が見つかりません
E: パッケージ hopalong が見つかりません
E: パッケージ hypercube が見つかりません
E: パッケージ imsmap が見つかりません
E: パッケージ maze が見つかりません
E: パッケージ pedal が見つかりません
E: パッケージ 'stars' はインストール候補ではありません
E: パッケージ xearth が見つかりません
E: パッケージ 'xeyes' はインストール候補ではありません
E: パッケージ 'xeyes' はインストール候補ではありません
E: パッケージ 'xgc' はインストール候補ではありません
E: パッケージ xgolgo が見つかりません
E: パッケージ 'xlock' はインストール候補ではありません
E: パッケージ 'xlogo' はインストール候補ではありません
E: パッケージ xroach が見つかりません

試したこと

上記以外にも

sudo apt-get install x11-apps:i386 x11-apps

と実行したところ、

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
x11-apps はすでに最新バージョン (7.7+5+nmu1ubuntu1) です。
x11-apps は手動でインストールしたと設定されました。
インストールすることができないパッケージがありました。おそらく、あり得
ない状況を要求したか、(不安定版ディストリビューションを使用しているの
であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:
以下のパッケージには満たせない依存関係があります:
x11-apps : 競合: x11-apps:i386 しかし、7.7+5+nmu1ubuntu1 はインストールされようとしています
x11-apps:i386 : 競合: x11-apps しかし、7.7+5+nmu1ubuntu1 はインストールされようとしています
E: 問題を解決することができません。壊れた変更禁止パッケージがあります。

と出てきました。

補足情報(言語/FW/ツール等のバージョンなど)

環境はubuntu16.04LTSの
gnome-terminal
bash
です。
よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

念のためですが、次のコマンドでパッケージリストは最新化しましたか?

$ sudo apt-get update

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/06 17:49

    ご回答いただきありがとうございます。
    $ sudo apt-get update
    をやって
    同じく上記
    $ sudo apt-get install ...(省略)
    とコマンドを実行したのですが、
    やはり結果は同じでした。
    お気づきだと思いますが、
    インストールしようとしているソフト(?)は
    大半がジョークコマンドです。
    Linux文化に少し触れてみたいと思い興味を持ったのですが、
    ディストリビューション等の関係でubuntuには対応していないのでしょうか?

    キャンセル

0

パッケージが提供されていない、もしくは、別の名前で提供されているのだと思います。
一つ一つ apt search で探してみてください。
例えば、xeyes は x11-apps に含まれているようです。
starts は無さそうです。

# apt search xeyes
Sorting... Done
Full Text Search... Done
x11-apps/xenial 7.7+5+nmu1ubuntu1 amd64
  X applications

# apt show x11-apps
  (略)

また、x11-apps:i386 と x11-apps(:amd64) はどちらか一方しかインストールできないのではないでしょうか。
64 bit 環境ならば、x11-apps でいいと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る