質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.65%

railsをインストールしたい

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,909

algorithm

score 5

前提・実現したいこと

railsをインストールしたいです。

発生している問題・エラーメッセージ

c:\rails\work>gem install rails
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
ERROR:  Error installing rails:
        ERROR: Failed to build gem native extension.

    current directory: C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/nio4r-1.2.1/ext/nio4r
C:/Ruby23-x64/bin/ruby.exe -r ./siteconf20160904-9016-3h0ntq.rb extconf.rb
checking for unistd.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby23-x64/bin/$(RUBY_BASE_NAME)
C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:456:in `try_do': The compiler failed to generate an executable file. (RuntimeError)
You have to install development tools first.
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:587:in `try_cpp'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1091:in `block in have_header'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:942:in `block in checking_for'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in `block (2 levels) in postpone'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in `open'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:350:in `block in postpone'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:320:in `open'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:346:in `postpone'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:941:in `checking_for'
        from C:/Ruby23-x64/lib/ruby/2.3.0/mkmf.rb:1090:in `have_header'
        from extconf.rb:3:in `<main>'

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  C:/Ruby23-x64/lib/ruby/gems/2.3.0/extensions/x64-mingw32/2.3.0/nio4r-1.2.1/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/nio4r-1.2.1 for inspection.
Results logged to C:/Ruby23-x64/lib/ruby/gems/2.3.0/extensions/x64-mingw32/2.3.0/nio4r-1.2.1/gem_make.out

該当のソースコード

gem install rails

試したこと

windows10を初期化した。

補足情報(言語/FW/ツール等のバージョンなど)

windows10 ruby 64bit 2.3.1 
DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exe 
rubyinstaller-2.3.1-x64.exe

参考したサイトは 
https://www.oiax.jp/rails/zakkan/rails_4_2_installation_on_windows.html 
Ruby on Rails 4.2 を Windows にインストールする手順をかなり丁寧に説明してみました

書籍は、 
Ruby on Rails 5.0 インストール手順書  
改訂3版 基礎 Ruby on Rails 基礎シリーズ

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

Windowsでは、ruby2.3でrailsを使うには工夫が必要です。

こちらも参照

特に理由が無ければ、2.2系で導入する事をお勧めします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/05 20:33 編集

    自己解決しました。Rails 5.0.0.1は、公式でruby2.2系が対応しているようです。ちなみに、ここを参考にしました。http://qiita.com/irigadon/items/907a276569f7f49bc564
    2.2系にすることは参考になり、助かりました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.65%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る