質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.22%

Xamariinで作成したプロジェクトのコンパイルで、Level16のAPI(Android4.1.2)が足りないと言われてしまいます。

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,127

GiveAHand

score 276

Xamarinで作成されたプロジェクトをコンパイルすえると、下記のメッセージが出てコンパイルが出来ません。

Could not find android.jar for API Level 16. This means the Android SDK platform for API Level 16 is not installed. Either install it in the Android SDK Manager (Tools > Open Android SDK Manager...), or change your Xamarin.Android project to target an API version that is installed. (C:\Users\XXX\AppData\Local\Xamarin\MonoForAndroid\AndroidSDK\platforms\android-16\android.jar missing.)    AutoChangeAirPlaneMode

Android SDKから、Level16のAPIをインストールすると、どうもXamarineが欲しい場所へのインストールではないらしく、エラーメッセージは無くなりません。

Visual Studioのインストーラーを立ち上げて、APIをインストールしようとすると、Level19からしかなく、level16が選択できません。

このような状態なのですが、このような場合、一体どうしたらいいのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

解決されているようですが一応。

yona さんの推測通り、 Visual Studio(Xamarin) は Android Studio とは別の場所に Android SDK をインストールします。

上記リンクの中ほどの画像で、Visual Studio から、Visual Studio が使用している Android SDK の SDK Manager が起動できます。

Xamarin を使用していて足りない API セットは、こちらからインストールできます。

※Visual Studio と Android Studio が使用する Android SDK を共通の場所にすることもできますが、開発に慣れてから必要ならば調べてみるとよいでしょう。

一方、 Java については、Visual Studio(Xamarin)が別のものを使用することはありません。
Android Studio での Android アプリ開発で Java のバージョンエラーが起こらなければ、 Xamarin.Android でもエラーは起こらないでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/05 22:14

    amay077様

    お世話になります。
    ご回答ありがとうございます。

    これはわかりやすいです!
    試してみます!

    キャンセル

0

Xamarinは使ったことがないので推測です。
AndroidSDKが複数箇所にインストールされているのでしょうか?Xamarinが使用している方でインストールは出来ませんか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/09/02 07:46

    yona様

    お世話になります。

    すみません。
    コメント書いた後に調べたところ、
    javaのバージョンが違うという書き込みなどを見つけ、
    どうも、

    http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

    ここから8u101、8u102共にダウンロードし、現在java8の更新102なのですが、
    それではダメです。

    javaのバージョンが違うというのは、一体どういう事なのでしょうか?

    キャンセル

  • 2016/09/02 08:28

    JavaコンパイラとJavaのバージョンがあっていないんじゃないですか

    もともとの質問とは異なるので、もう少し調べてわからなければ再度、別質問として投稿してください。
    また、この質問は過去に見たことがあるので質問の検索をしてください。

    キャンセル

  • 2016/09/02 10:37

    yona様

    了解しました。
    いろいろとありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • トップ
  • Androidに関する質問
  • Xamariinで作成したプロジェクトのコンパイルで、Level16のAPI(Android4.1.2)が足りないと言われてしまいます。