質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

cakephpのMigrationプラグインが急に使えなくなった。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,454

takumi123

score 33

前提

  • vagrantを使ってローカル環境で開発しています。
  • cakephp 2.8.5
  • php 5.6.22
  • CakeDC Migrations Plugin master最新版を直接ダウンロードしました。
  • 構成ファイルのすべての所有者はvagrantで、パーミッションは777です。また、vagrantでログインしているため、すべての権限を持っています。

CakeDC Migrationsプラグインのインストールもできています。

  • app/PluginフォルダにMigrationsという名前で配置
  • app/Config/bootstrap.phpにCakePlugin::load('Migrations');と入力済み

発生している問題・エラーメッセージ

今まではMigrationプラグインを使えていたのにもかかわらず、急に使えなくなりました。

コンソールで以下を実行しました。

[vagrant@localhost Console]$ php cake.php Migrations.migration generate

エラーメッセージは以下になります。

Error: Plugin Migrations could not be found.
#0 /vagrant/app/Vendor/cakephp/cakephp/lib/Cake/Core/App.php(227): CakePlugin::path('Migrations')
#1 /vagrant/app/Vendor/cakephp/cakephp/lib/Cake/Core/App.php(549): App::path('Console/Command', 'Migrations')
#2 [internal function]: App::load('MigrationShell')
#3 [internal function]: spl_autoload_call('MigrationShell')
#4 /vagrant/app/Vendor/cakephp/cakephp/lib/Cake/Console/ShellDispatcher.php(252): class_exists('MigrationShell')
#5 /vagrant/app/Vendor/cakephp/cakephp/lib/Cake/Console/ShellDispatcher.php(203): ShellDispatcher->_getShell('Migrations.migr...')
#6 /vagrant/app/Vendor/cakephp/cakephp/lib/Cake/Console/ShellDispatcher.php(66): ShellDispatcher->dispatch()
#7 /vagrant/app/Console/cake.php(47): ShellDispatcher::run(Array)
#8 {main}

今まではこれでうまくいっていたのですが、急にエラーになりました。

試したこと

  • Migrationプラグインを削除して、新しくダウンロード→変わらなかった
  • bootstrap.phpでCakePlugin::loadAll();→変わらなかった

ちょっと自分ではどうすればいいか分からなくなりました。
お手数かけますが、回答いただけると幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • takumi123

    2016/07/25 17:28

    回答ありがとうございます。
    確認しましたが、そのようなことはありませんでした。
    何度もありがとうございます。

    キャンセル

  • kunai

    2016/07/25 17:54

    app/tmp/cache/persistent 以下のファイルを全削除してみても動きません?

    キャンセル

  • takumi123

    2016/07/25 20:44

    返信が遅れて申し訳ありません。
    はい、指定ファイルをすべて削除しましたがダメでした。
    回答ありがとうございます。

    キャンセル

回答 2

check解決した方法

0

どうしても解決しなかったため、CakePHPを再ダウンロードしました。
するとうまくできました。

いまだに原因は分かりません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

自分も同じような状況になりました。

自分の場合は、Composer install を行ってcakephpの中にcakephpが入っていました。

Migrationのコマンドのパスを見ると、以下のプラグインを見ているようでした。
app/Vendor/cakephp/Plugin

そのため、app/Vendorのcakephpを削除して、もう一度実行するとうまくいきました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる